Pixhawk Swapping stick commands when rotated

Hi All,
I have been working on a new build using the pixhawk on a Blade 600x, the issue is this the pixhawk will swap pitch and roll commands. This happens when the heli is rotated in any direction other than the way it was facing when the setup in MP was done, north this time…
If I face it west pitch and roll are swapped (pitch is now roll and roll is now pitch), same if I face it east (except left/right switched and forward/back) pitch and roll still swapped
If I face it south pitch and roll are ok except forward/back is reversed and left/right is reversed, the odd thing is the swash will always try to level itself in the proper direction regardless of which way the heli is pointing.
So that tells me the servos are in the correct order on the main out pins, I only caught on to what has been going on for a whole week tonight and did make a video of it (It was makin me crazy).
The other odd thing is in MP in the heli setup tab, I put in my servo locations as #1at 0 ,#2 at 120, #3 at -120 and the compass rose corresponds with that.
However if I leave that page and come back to it, the compass rose now shows #1 at 180, #2 at 60, #3 at -60 yet my original numbers are still there… ( 0…120…-120 ).
I have uninstalled latest MP three times and have tried to load latest firmware to pixhawk even more all with the same results…
I purchased the pixhawk w/gps new from RMRC on march 5th and heard there were some issues with earlier units and am wondering if I have one??
Or if is something I am doing, attached is a screen shot of the heli setup tab and my video link.
I will try to down load what ever info is in the log file/sd card and post that as well tomorrow, I am hopful it is just something simple in my setup procedure…
Many Thanks
hope the video comes thru…

Hi all,
Well I tried two more tests last night after posting initial issue, I can arm the pixhawk no matter what and it does not make any difference which direction the heli is pointed in when initialized the end result is the same.
I found out that the new youtube tags will not post (re: adding youtube tag) , so I did make it public on my youtube channel :" tugboat4me" it is titled “pixhawk swapping channels” if anyone cares to look.
I did manage to download log files and will post a couple but I do not know what I am looking for, I am hopeful that it is something simple or compass related.
It does appear to be directional related when it initializes, as in what ever direction it is pointed when first initialized all stick commands work normally… it is when you turn it to face a new direction after it is initialized that the issue takes place. :unamused:
Tx cali has been done as well compass and accel cali, I was hunting in the pram’s menu’s this morning and at least was able to get my full collective travel back (don’t know what I did there…but its workin!).
So if anyone has an idea as to what I’m looking for in the log files… now would be the time :smiley:
I will be contacting 3dr support today and will post the results…
Please and Thank you in advance…

:smiley: :smiley: :smiley: :smiley: :smiley:
Hi all,
My 9 1/2 shoe is a excellent fit in my mouth, what was happening is normal for SIMPLE MODE!
So I just unchecked the boxes for simple mode in the flight modes screen, then rebooted the pixhawk and PRESTO!!!
All is good, I thought simple mode was what I had used in my QAV 400 quad but it blatantly is not. :blush: :blush:
Thank you to “Diego” at 3dr support!!!
One simple phone call was all it took, me so happy now :laughing:
This issue is now solved, as it was a non-issue to start with.