Pixhawk stop working (FMU freeze)

My Pixhawk froze again (latest master) amd with 3.2-rc2 too 2 days ago.

No communicate via telemetry or usb.

Leds: main led off
FMU leds: green solid
IO leds: green solid blue and orange blinking

3.2-rc2 because 3DR cannot wrote S.BUS patch to 3.1.5 since January.

3DR Pixhawk + GPS + Power module
Minimosd 798
R7008SB SBUS rx
3DR telemetry 433Mhz

I get the same thing on pretty much any trunk code compiled in the past couple of weeks (since rc2). Took a while to recover from it, but eventually flashing arduplane and than back to arducopter 3.1.5 managed to unbrick it, although I tried all sorts of combinations of booting with safety pressed and pixhawk/qgroundcontrol firmware so not sure what it was exactly that managed to release it. I’ve tried several times since and all the master/trunk firmwares in the last couple of weeks (compiled myself, not the ones downloaded from the firmware site) do the same thing, I have to back to a release version to unlock the pixhawk.


Besides that - it’s a known issue and being worked on.

Turns out the PX4Firmware tree had changed and I hadn’t cleaned and recompiled, so a fresh clone and recompile solved my problem. It does seem that the pixhawk can get stuck sometimes and needs some prodding and persuading to unlock itself. I had to unplug all DF13 connectors except for the power module and flash using ground control to unlock/brick mine. It might be helpful if the wiki had a ‘recovery’ page to address this as it seems relatively common with the pixhawk for various reasons.

3.1.5 not working with transmitter, 3.2rc2 freeze. (Copter)
So I cant use my Pixhawk. Why bougth this useless … :frowning:

Hopefully the final version of V3.2 will solve those problems. I have an APM and 3.2 rc2 had some stability issues. I was told that they were known issues and they were working on fixing them.

They finally got the Airplane firmware working well with PixHawk and Futaba Sbus so I assume they can use some of the same code for multirotors.