Servers by jDrones

Pixhawk reboot after fast rising from min throttle to nearly max throttle

(Toto Mauris) #1

I rebuild my flying wing due to summer update…

During motor test (on ground, manual flight mode), the board has restarted after fast rising from min throttle to nearly max throttle (not just disarm but reboot).

I reproduced the failure multiple times.

I don’t know where the problem comes from, powering problem ? I checked the wiring all seems to be ok…

(Khancyr) #2

Hello,

It is most likely a power issue. Check your battery. It is more probable that the current is too much for you battery and its voltage collapse. You could check with a voltmeter or with your flight controler and log disarmed on.
It could also be an issue from the flight controler power board that cannot handle the current/voltage surge on hight demand

1 Like
(Mike Boland) #3

It’s really hard for us to guess the problem if you don’t include a .bin file from the FC.

(Toto Mauris) #4

Its very hard to plug usb cable or remove the sd card…

I will try tomorrow (UTC+2)

If the board is powered by a voltage regulator and need no more than 5v, how a lipo 3s voltage collapse can disturbe the board powering… (I’m a software engineer, not electronic engineer…) ?

(Toto Mauris) #5

I retried today with multiples lipos (log attached), I think that vcc follow motor power demand…

00000003.BIN (124 KB)

(AMV) #6

Hi

What electronics do you have connected to the Pix? May be you are drawning too much amps from the Pix. For example, the RC RX, telemetry or may be a distance sensor. Is always easyer to get the power from the pix, because you dont have to cut any cables, but is recommended to get all the power for the electronics from 12 or 5V BECs.

Let us know.

bye!

(Toto Mauris) #7

Hi

Thanks for your help ! Do you think that vcc is abnormal ?

Why motor high demand can have an influence on vcc board ?

(AMV) #8

No, that fluctuation is normal, if you just see the line graph, sure seems to be a lot of voltage difference, but if you see the numbers, the voltage variation was just 0.06Volts, that must not be a problem to the PIX. One time I was runing a Pix with 4.2V (dont do it), and works, but the idea is not to work under 5V, so you VCC is normal.

What can make your pix reset is the current on the pix cant be delivered to all the electronics. Thats why I have asked you what do you have connected to the board. One time I have connected 2 TFMini distance sensor to my Pixhawk 2.1 Cube, and at the moment of the takeoff, the pix reset. Taking the TFMini power to the 5V BEC did the trick and no more reset.

Let me know about your electronics connected to your pix, bye!

(Toto Mauris) #9

I have rc receiver (radiolink r6ds) and minimosd powered by the pix.

But why motor high demand can have an influence on that ?

(AMV) #10

I really dont know the awnser, As I told you before, every time my hexa try to takeoff, the Pix get reset, and after I took the sensors power out of the Pix, the problem was solved.

The RC seems to be very little, and just 45mah, must not be the problem.

Anyway, try to connect the RC and OSD to a 5V BEC and let us know the result.

And of course, the las firmware to the Pix.

(Toto Mauris) #11

I tried with nothing powered by the pix, same result :frowning_face:

(AMV) #12

ok, so you have to start to test all the parts, may be something its doing shortcut. do you have another Pix and ESC to test each part?

Do you have a GPS and compass connected to the pix? You have to discard that too.

(Toto Mauris) #13

radiolink mini pix power module can’t supply enough power ?
I have 2205 2300kv motor (reptile s800) flying wing

(AMV) #14

May be, at this point you have to start to discard any electronics. My nose is telling me you have to start changing you pix flight controller, if the pix still reset, then your ESC (as the PIX restart at full TH). If you keep having the reset, change the PM.

(Shawn) #15

Have you got a photo of your wiring, with pix and accessories?

(Toto Mauris) #16

Powering board “wiring”, the motor wires are soldered on power board connectors but not directly on battery (may be solder the motor wires directly with battery wires… ?) but I don’t know how much current the power board can supply… its radiolink mini pix power board

(lulu) #17

it won’t help a lot but you’re not the only one :
https://discuss.ardupilot.org/t/fw405-wing-rebooting

I also have this issue with an omnibus F4 or F7 board when using a certain type of RX with ppm. Fast rising throttle make the board reset.
I did not have the time to dig into this yet

(Toto Mauris) #18

Are you sure that your problem came from rc receiver ? Mini pix only works with ppm…

(lulu) #19

no, not sure at all, sorry. Need more testing.

(Toto Mauris) #20

Your motor is directly wired to vbat… ?