Servers by jDrones

Pixhawk not changing flight modes


(Nasos Bax) #1

I have a pixhawk px4 and when i try to change my flight modes it stays on acro mode.I am using mission planner to change the settings and i have completed the wizard but whenever i try to change the mode it just stays on acro.

What might be the problem ?


(Nasos Bax) #3

Yes i did but it doesn’t seem to save them


(Nasos Bax) #5

Through the mission planner wizard. The MP won’t respond to the transmitter switch


(David ) #6

On your MP, just calibrate again your rc and set again the flight modes without use the wizard


(David Garrett) #7

what radio unit are you using, as settings may have to be adjusted within the radio settings to enable the flight modes to be recognised…(I have to to do this on my Turnigy 9x)

like this… https://www.youtube.com/watch?v=6n_5wNA2jTI


(Edward R.) #8

Hi Nasos,

With the propellers off of your drone, try the following:

Connect your drone to QGroundControl, once you are connected to it, go to the Flight Tab (tab where you monitor the flight). On the top, it should show the flight mode it is in (if what you state is correct, this should display Acro). When you click on it, a dropdown menu will show up, and you can select a different flight mode, try “Stabilize”.

If you are able to do this, and the flight mode changes, your issue is with your RC Controller.

Let me know how this test goes.

Best,
E