Pixhawk Mini - No Yaw Control


Recently, I decided to get two PixHawk Minis and integrated one for my 250 quad. Everything is built, software loaded and able to get the vehicle armed and hovering however, the quad is not responsive to any yaw input while in hover. Oddly enough pitch, roll and throttle work just fine. Something seems off since I able to arm and disarm using the yaw/rudder input. This feature is consistent even for the second PixHawk Mini that I purchased. Also, I observed the same effect for two different receivers. I also tried reloading the firmware for both the Pixhawk Mini and ground planner.

So my setup is as follows:

  • Pixhawk Mini with 1.6.5d firmware
  • Quadcopter “X” configuration
  • QgroundControl version v3.2.4 (note I tried Mission Planner and reloaded Mission Planner but it could not recognize either of the two PixHawk Mini flight controllers)
  • QAV 250 frame selected in QgroundControl
  • Spektrum w/Dragon Link transmitter and receiver with V3 software loaded - and - tried Spektrum DX8 with Orange Rx R820X V2 8Ch DSM2/DSMX receiver

Current Key Parameters:

MC_RollRate_P 0.114
MC_RollRate_I 0.045
MC_RollRate_D 0.004
MC_Roll_P 6.00 1/s

MC_PitchRate_P 0.114
MC_PicthRate_I 0.045
MC_PitchRate_D 0.004
MC_Pitch_P 7.00 1/s

MC_YawRate_P 0.200
MC_YawRate_I 0.020
MC_YawRate_D 0.000
MC_Yaw_P 4.00 1/s

Any thoughts for a remedy…probably something simply I overlooked. Thanks all.

I am not sure if this is a PixHawk Mini problem, or an ArduCopter configuration problem. In case you don’t get a response here (on the Hardware forum), try posting on the ArduCopter forum.

It’s running the PX4 flight stack so it wouldn’t be a Arducopter related problem and the reason it won’t connect to Mission Planner. Try over on the PX4.io discussion forum. Or you could load Arducopter and give it a try as I understand the Pixhawk Mini is supported in the current Rev. There isn’t a lot of chatter about it though…

1 Like

The Pixhawk Mini is supported in Copter 3.5. I’m flying one in a 626 helicopter and it is a very nice flight controller. It is the same thing as a PixFalcon but with updated IMU’s in it. The -v2 Copter build for whatever aircraft you are flying should load right in it with no issues.


I will roll this over to the PX4.io discussions. So, my matrix is as follows:
Pixhawk Mini

  • APM Planner (yes, able to sync up)
  • Mission Planner (not, able to sync up)…copy and understand the Pixhawk Mini is running the PX4 stack
  • QGroundControl (yes, able to sync up)

I cross checked this with two PixRacers I have:

  • AMP Planner (not able to sync up)
  • Mission Planner (yes, able to sync up)
  • QGround Control (yes, able to sync up)

My APM Planner is super buggy, even after multiple re-loads plus I have yet to fix the DPI font issue. I just thought there was a little more cross pollination with the latest firmware, kind of like what we see with CleanFlight and BetaFlight – Still working to solve that “no yaw” issue.

I use QGroundControl or Tower on Android and haven’t had any issues. For loading firmware I use APM Planner2 on linux and no issues with that either. I do not fly the PX4 stack, only ArduPilot. And have not tried Mission Planner in several years as I don’t have a Windows computer.

I also do not have buggy problems with APM Planner2 on linux. Have never tried it on Windows or Mac for the same reason - all my computers run either linux or Android.

I would not expect Mission Planner or Tower to work with the PX4 stack as they are developed specifically for ArduPilot. I would expect QGroundControl to work with either. There is no interoperability between QGroundControl’s JSON file format for mission plans and MP or Tower’s .txt file format. All three can upload flight plans to the Pixhawk, but you can’t move flight plans directly from QGroundControl to MP because MP doesn’t know how to parse the JSON file format. QGroundControl’s .params exports are also different than the .param exports from MP or Tower.

Of the three, QGroundControl is probably the most flexible.