Pixhawk Just Falls Outs The Sky

Ok, Probably a bit dramatic but this happened three times today for no real reason!

Flying around normally and then I loose control and my quad goes nuts. It appears that recovery may be possible but luckily not from a great height! The quad was only 20m max from me!

Here is a link to the last flight’s log.


Would love to get to the bottom of this.

By the way, I have a Mavlink on board and no GPS glitches or RSSI issues.

Here is the onboard video of the failed flight.


Everything was going well till the end!

From the logs and the video motor 2 failed causing the copter to pitch upward and then crash. Don’t know if its a sync issue or something in the motor.

Of course now there is something in all of the motors…


Mike, many thanks for looking.

Firstly, how did you come to that conclusion? For reference.

Secondly, what do you mean by something us now in all motors?

Many thanks.



From the graph we can see that Motor 1 went to low speed and Motor 2 went to max. At the same time the pitch went up which is why it cut power to motor 1.

The second time this happened is when you touched down on the beach which again we can see the unit pitched up by a lot and again it cut power to motor 1 and tried to power up motors 2 and 3 to recover from the sever roll to the left.

Because the unit recovered itself in between it would indicate that the motor stopped for a short time and then started to spin again. Thus is it a motor sync issue or was a piece of dirt in the motor that temporally stopped the motor.

Now that the unit crashed onto the beach it has a lot of sand and dirt near the motors and may need cleaning.



Many thanks for your analysis.

How did you get that information?

I have looked at the log in Missionplanner but can’t see how or where you got that info from?

Am I missing something?



So I’ve managed to create a .log file as well as 2 KMZ files for Google Earth and a .gpx file.

I’ve opened the .log file in Mission Planner and this is displayed.

[attachment=0]Log File.jpg[/attachment]

How do I get to what you have displayed?



I worked it out!