Pixhawk HUD Drift

Just built up a Tarot 650 with a shiny new Pixhawk. Calibrated everything several times after installing newest firmware. All seems good with 11 sats and hdop @ 1.4.

As soon as I arm the copter the HUD will roll right so it’s not safe to take off.

Any ideas Please.


Hi Jim,

I had the same symptoms out of the blue also with my pixhawk, recently flashed with new firmware. I redid many times the accel calibration but that would not solve the HUD drift issue. An indeed impossible to take off, my quad flipped trying…

So the only way I solved this was to completely erase and rereflashed the Pixhawk (to be sure I erased everything I flashed an arduplane firmware then the arducopter firmware).

Try that and see if it solves your issue too.

After the reflash, did you reload your previous parameters? From a previous file of your own? Or the standard Pixhawk parameters?


I ask because I’ve also had the same problem. It has gone away (while I had 3.1 installed) but came back with 3.1.2. I haven’t tried erasing and then reloading again, other than revision updates tehmselves, that apparantly erases existing.

The problem, in my case is sometimes worse than others. It will always “flatten out” after several minutes “warming up”, and after several ARM / DISARM cycles.

One should wait at least 3 minutes (more is better) before taking off after first 3D fix. The GPS needs to “settle in”.

Thanks so much for posting that suggestion.

Worked really well at first. After the reflash HUD was rock steady, although the problem seems to be returning. Will test some more in the morning.

Thanks again,


@Sky, After reflashing I add indeed to redo every calibration and redo every parametrization… It is a pain indeed.

I just noticed this afternoon that my Pixhawk showed again signs of drift on the HUD… So it is a problem that comes back! I
hope 3DR reads this to find the root cause because it is unacceptable to have to reflash your board every once in a while. :cry:

I had my Pixhawk all setup and calibrated. This morning I plugged in the lipo held the safety switch button until it went solid red and tried to arm. It wouldn’t arm, so I plugged it into Mission Planner and the HUD was spinning constantly. Doing an erase and then a reset via the terminal fixed the problem.

This is pretty disconcerting! Has anyone figured out what causes it?

I’m using firmware V3.1.2

I got the information about doing an erase and then a reset via the terminal to fix the problem from this thread:
diydrones.com/forum/topics/hud-i … r-spinning

Quick update,

The drift has defiantly come back. I did improve after arming/ disarming five or six times.

Very puzzled now.

Finally got around to recalibrating everything. All was fine until I did the compassmot calibration. When I reconnected Mission Planner after doing the compassmot calibration the HUD is spinning again. The results of the compassmot calibration was 0%.

It appears there is a known bug related to compassmot and Pixhawk:

diydrones.com/group/arducopterus … e=activity

If you are using an external compass Just set your compass mot values to 0

You can also load trunk and do a compass mot there and then revert back to 3,1.2