Pixhawk going to extremes

When I turn the right-stick in circles, the Pixhawk seems to crash, and the servos go to extreme positions.
You can see it in my video here:

Does anyone know what causes this? I couldn’t find anything on the forum describing anything similar.

I just recalibrated the radio and everything.
I also just flashed the firmware to the latest stable version to see if that would help.
I can attach a log if people haven’t seen this before. This is a real Pixhawk, not a clone.

Thanks everyone!

To help troubleshoot your issue please provide the following:
Type of UAV
Loaded firmware type and version
Ground Control Station type and version
tlogs and/or dataflash logs captured during the issue in question.


This happens even when the GroundStation is not connected, so the version of Tower I use isn’t really relevant.

The UAV is a fixed-wing Sky Mule. No Ailerons.
I’m running a PixHawk, and I just uploaded the latest firmware and the problem persists. The version is 3.4.0.

What doesn’t make sense is that you are in manual mode and that the RCIN values match RCOUT, so the pixhawk doesn’t look like it is requesting full deflection At the end they have returned to normal mid-point. Are your servos doings something odd at the extremes?


I know… the logs say that they’re working right, but they’re not.
It happens in Manual or FBW A, and perhaps all modes.

The servos are just all simultaneously deciding to go to an extreme and stay there. Fortunately Throttle is going to 0.

Ok, Problem Solved.

I wanted to reproduce the problem, so I plugged in the Throttle (with powered line) and Rudder, Elevator.

I could not get it to happen.

I then plugged in ALL servos.

The Servos that this requires are:
[li] A front steering wheel servo, sharing the Rudder[/li]
[li] A Rudder[/li]
[li] Elevator[/li]
[li] Two Ailerons[/li][/ul]

All this running off the ESC built in BEC.

It turns out, the draw these have when being rapidly pused to extremes is enough to cause a brown-out on the power line for the servos. Just this pulse is enough to make the servos all do this behaviour, which I guess persists even when the power restored.

To fix it, I added another ESC to the mix, which gave it sufficient power to never brown out.

A more permanent solution will be to run a BEC straight from the battery, as I’ve done in other planes.
Perhaps I’ll try to duplicate this without the Pixhawk even attached, but for now, I’d just like to call this one solved.

Always run a BEC just for your servos. Never rely on the power that come from the ESC.
Who would have guessed it would have this behaviour.

Thanks for your help.

You shouldn’t have two power sources on the servo rail, as they will ‘compete’. By this I mean that the higher voltage supply will create a current flow to the the lower. The comes from the fact that ‘batteries in parallel’ and hence ‘regulated voltage supplies in parallel’ will try to equalize. the current that flows will create heat in the regulators which will result. potentially, in damage or a shorter life span. In ‘switch mode’ regulators you can get an unsteady voltage as well.

Just use one BEC (or ESC/BEC with connected 5V line), with enough Amps for your needs.*

Hope that helps :slight_smile:

*If you do some googling you will see that people will say you can use regulators in parallel if they are ‘linear’ ones. This is true as they use resistance to keep the voltage constant. The resistance dissipates heat, so they are good at being hot, so less flaky. If the voltages are exactly the same it also OK. just when you ix and match regulator types, and voltages its problematic.