Pixhawk drivers not being recognized

I have had my IRIS since February 2014 and just recently upgraded to IRIS+ . I have correctly loaded AC and well as the latest release of Mission Planner. I have been successfully communicating with MP using MAVlink but have never been able to connect via a USB. I re-installed MP on my Windows 8.1 laptop (Dell XPS 13)and disabled driver signing. However no luck. I saw in a post from last year (Marc h 2014) that someone had switched cables and afterwards was able to connect via USB. I tried 2 separate cables and still no luck. So can anyone suggest what my next steps should be?

You might try using a powered USB Hub.

Thanks. I will try that. Just for giggles here is the error appearing in device manager:

"Windows has stopped this device because it has reported problems. (Code 43)

A request for the USB device descriptor failed."

This issue is solved. I found one of the wires on the DF13 connector on the cable from the external USB plug to the Pixhawk was loose. So I re-inserted it and applied some liquid electrical tape to the DF13 in order to hold it all in place. I will probably have to get a replacement cable but in the meantime all is good. In fact I reloaded the drivers with driver signing enabled on Windows 8.1 and they loaded without error.