Pixhawk dataflash logs problem

Hello all, thanks for reading this. After my first two days of flying after the buid, I wanted to review my logs. Very unexpected I ran into trouble with this. First I tried to download the logs in MP (v1.3.31 build 1.1.5696.33420) using my telemetry connection. I quickly discovered this link is slower than a data link to the moon. :slight_smile:

I then took my micro SD card from the Pixhawk and loaded the .BIN files directly on my computer. I found out I can both “Review a Log” using the .BIN file, and using the “PX4 .Bin to .Log” option. Both worked for my first log (number 43). However all the log files after that, do not work using either method. Even when dowloading a single log file directly into MP with the telemetry link or USB connection (I drilled a hole in my aircraft to be able to connect the micro USB) it doesn’t work. Except for log 43 (or older logs), those work every time.

[attachment=0]Mission Planner error.JPG[/attachment]

[attachment=1]Mission Planner log browser.JPG[/attachment]

Links to both the usable and unusable .BIN files:

43.BIN:
dropbox.com/s/rw3q71ykol5wx … 3.BIN?dl=0

44.BIN:
dropbox.com/s/5ye5c5u46xe2o … 4.BIN?dl=0

SOLVED

I used a micro SD that wasn’t fast enough. Class 10 now, and no logging problems.