Pixhawk Cube USB connection problems with Mission planner

Hello,

I have recently purchased a new laptop. I never had any issues with both laptops used before but with this new laptop, I am having problems establishing a USB connection between a Pixhawk cube and mission planner.

The only way I can connect is as follows:
1- Start mission planner.
2- Connect the USB cable between Pixhawk and the laptop.
3-Wait for the USB connection sound, then the USB disconnection sound as pixhawk reboots.
4-press “connect” on mission planner right after the USB disconnection sound, as pixhawk is rebooting.
5- Most of the time, mission planner will connect as pixhawk reboots.

I say “most of the time” as the timing in clicking “connect” seems critical. If I do not have good timing, it will either not connect (connect failed), or it will stay in the “trying to connect” state until the timer counts down to 0, and then issue a “connect failed” error.

Also, if I do manage to connect, and I press “disconnect”, then I cannot connect again. I need to repeat the above steps (unplug the USB cable, re-plug, wait for reboot, press “connect” at the right moment).

Trying to re-connect after a manual disconnect will give the following error message in the console:

ERROR MissionPlanner.MAVLinkInterface - System.IO.IOException: Access is denied
at System.IO.Ports.WinSerialStream.ReportIOError(String optional_arg)
at System.IO.Ports.WinSerialStream…ctor(String port_name, Int32 baud_rate, Int32 data_bits, Parity parity, StopBits sb, Boolean dtr_enable, Boolean rts_enable, Handshake hs, Int32 read_timeout, Int32 write_timeout, Int32 read_buffer_size, Int32 write_buffer_size)
at System.IO.Ports.SerialPort.Open()
at MissionPlanner.Comms.SerialPort.Open()
at MissionPlanner.MAVLinkInterface.OpenBg(IProgressReporterDialogue PRsender, Boolean getparams)
map render 0.0069769
HUD 1 hz drawtime 2 gl True
INFO MissionPlanner.MainV2 - comport is closed. existing connect
map render 0

It appears that somehow, mission planner must connect just as pixhawk is booting up, or it will fail. I have experienced the same situation with 3DR radios as well. It looks as if the COM port remains open after being closed, preventing further connections. Trying to update the firmware of a Pixhawk APM seems to confirm this as the new firmware will install, but the program will stall after pixhawk reboots.

This is specific to a brand new Dell G5 laptop. I have tried the same pixhawk cube modules on different laptops, and I do not experience this issue.

Steps I have tried to resolve the problem:
-I have tried multiple pixhawk modules on multiple computers (we own 35 drones). This problem is specific to one computer and not related to the auto pilot module being used.
-I have uninstalled the USB root hubs and re-installed them.
-I have assigned different COM ports.
-I have uninstalled the anti virus software.
-I have disabled power management on the USB root hubs.
-I have lowered to “1” the transmit and receive buffers of the COM port.

I am now running out of ideas as to how to resolve this problem.
Has any of you ever experienced a similar issue? Did you manage to fix it?

Any help will be appreciated.

Sincerely,

Patrice Guy