Pixhawk compass will not calibrate


When trying to calibrate the Pixhawk compass, I go to the comapss calibration tab and click the Live calibration, it asks if my firmware is higher than some version and i click yes because I have the newest one, and the sphere screen comes up.

It collects 3 samples instantly and when I move the copter around, nothing happens, nothing rotates in the screen, no samples are collected other than the 3 from the beginning.

I have tried different computers, all the different APm with external compass and so on, this is a Pixhawk with U-blox GPS with compass (genuine 3DR)… Please help!

The flight data screen shows, when i tilt the copter the artificial horizon moves and everything, i get GPS lock, but the calibration does not work… And I get the PreArm compass not calibrated.

I tried loading Plane and then reloading copter again with no luck. I did manage a compass calibration when I first connected the board, but that was before i connected the external GPS/Compass.

So i tried disconnecting the I2C cable, and then it works fine. So it’s only with the Mag to I2C cable connected that it just stops calibrating.

Also tried switching the I2C cable, and going through the I2C splitter, no luck.

I made this short video describing the problem


3DR Support saw this as an RMA, waiting for replacement now…

This is exactly the same thing happening to me. I suspect they had a bad batch of boards.

I had a similar problem and called tech support several times. They had me reload firmware, etc. and check parameters list, which showed no compass data. The tech said I needed a new Pixhawk. Great! I haven’t even flown this one yet and I was out of the 3 month warranty (I was compiling parts for the build over a period of time). I did connect it and boot it up after first receiving it and before building my quad and it always said “compass not healthy”. I thought this was simply because I hadn’t calibrated it yet.

Anyway, they would not replace the board, but instead, offered me a 15% discount on a new board. I was not happy. After repeated attempts at satisfaction, they upped the discount to 25%. So, rather than scrap everything, I bought a new Pixhawk.

Before tearing the old/still new board out, I thought I would try to calibrate it again, since I now have a PC and can run Mission Planner, which has a much better compass calibration routine than the APM planner software. Still no points showed, until I unplugged the GPS/Compass module. The compass calibrated fine. Plug the GPS back in and no compass.

So, is it the GPS module that is bad? or the Pixhawk board? I would rather replace the $89 GPS module and return the second Pixhawk, if it is indeed the problem.

Did you check if you have external compass enabled? There is a variety of settings related to this, like ArduCopter:MAG_ENABLE and COMPASS_PRIMARY, all described here:
copter.ardupilot.com/wiki/arduco … mag_enable . You may also want to disconnect your GPS compass cable (DF13 4-pin connector), but keep GPS cable (6-pin) plugged. While external compass is disconnected/disabled, try to perform a calibration. If you succeed, then you know that your internal Pixhawk compass is alright. Therefore you can go next to troubleshooting the GPS compass problem.

If you still cannot calibrate with GPS and external compass connected, I would verify the cable (first). Also see if there is any physical damage on the GPS. You may also verify if the compass orientation for external compass is set correctly (COMPASS_ORIENT, relative to Pixhawk placement).

Full reset of Pixhawk setting would be useful too.

Thanks! I found the problem. I had calibrated the Pixhawk’s compass (GPS module detached). No problems there. After considerable searching I found that I had mistakenly had the 5 wire cable, not the 6 wire, plugged into the GPS module. They look so close, I hadn’t differentiated between the two.

I feel kind of foolish, but at the same time, am a bit disappointed that the info about this wasn’t marked a little more clearly in the documentation and that 3DR’s tech support didn’t help me troubleshoot this. They told me I needed a new Pixhawk, which I bought. Oh well, now I have one for a second build.

Thanks again for the advice.