PIXHAWK communication with PC

Hi, I am Trying to communicate with the Quadcopter having the PIXHAWK and 3DR radio.
I have the 3DR radio connected to the quad and another unit to my LAPTOP. I am running Mission planner on my laptop and I am able to get the telemetry data on the mission planner. how ever I have a program running on my laptop separately which is taking images from my fpv camera and running analysis on it. when there is an event generated by the program on the laptop, I need to be able to control the quadcopter through my laptop, I learnt a way to do it is by MAVlink. but how do you communicate with the quadcopter with the MAVLINK, I mean to ask what sort of hardware should I use? Will the 3DR radio do the job of sending the command to the quad?

The 3DR/SiK radio will handle the communications fine: what you need is a way to get your message to it, in the correct format. There are a number of ways to do this: you can use MAVROS, with your imaging software running in ROS and then output to MAVLink via MAVROS, you can use Dronekit-python (http://python.dronekit.io), or MAVProxy. Any of these methods can be run from your groundstation, and control the drone over the telemetry link, or you can put a companion computer on the drone and interface locally over serial.

thank you, James Pattison for the direction! So, to send the command to the drone via 3dr telemetry should I have the mission planner up and running and send the commands through the mission planner UI? Also, i was wondering if I use a Raspberry Pi to communicate using the WiFi of Raspberry Pi connected to a common network with the Laptop, will the wifi interfere with the FrSky Rx on the quad?

use mavproxy to talk to both dronekit and missionplanner (or any other compatable gcs software).
mavproxy.py --master=COMn --out= --out=
where COMn = your com port for the SiK radio.
Then connect mission planner to UDP port 14550 and dronekit to UDP port 14551.

wrt 2.4GHz interference, it really depends on how you have the wifi and rx set up. If you physically separate the wifi and rc rx antennas, and turn off Rx telemetry, so it is a listen only device, then the wifi won’t be interfered with - but you need to check to see if rc is. You can also try https://befinitiv.wordpress.com/2015/08/26/enable-2-4ghz-rc-systems-to-work-with-2-4ghz-video-systems/ if you have a problem, but it’s pretty in depth.

thank you! I will try with that.