Pixhawk Calibration Failure

Hello, i just completed a build of the 3DR 2014 DIY quadcopter kit. This is my first build and first time using Pixhawk. i am using APM for Mac and have connected directly (USB cable) or via telemetry radios to APM with success. I updated the firmware successfully, and I have successfully bound it to my Spektrum DX7 radio.

I have been following instructions on this page: ArduPilot > APM Planner 2.0 > Calibration: Radio Calibration

I performed compass and accelerometer calibrations, which seem to have worked (i did not get any errors), and the radio appears to properly interact with the system as judged by the movement of the green bars in the radio configuration graphical view.

However i can not complete the setup. When i hit the “end calibration” button I get the error dialog indicating failure to calibrate, radio disabled or not functioning" (sorry i dont have the exact wording i am away from the configuration). The pixhawk is flashing the double yellow signal. Please help! I’m so close, yet so far! Thank you. Nick

Hi Again, i have tried again and am adding details. I am getting a voice message saying “PreArm check: RC not calibrated”. When i hit the calibrate button on the radio calibration view i get the error message “radio control is not active or turned on”

Update on issue:

  • compas and accelerometer calibrations appear to be OK
  • radio calibration appears to be working, but when i hit the ‘calibrate’ button i get the message: “radio control is not active or turned on”

This is still an issue i am hoping to get help on. I am sorry i can’t figure out how to edit my post so i am adding a few more details as a reply if they are helpful:

  • i am using this radio Spektrum DX7 7 Channel System w/ AR8000 Receiver Mode 2
    model SPM7000 (this is a new release of the DX7 (spektrumrc.com/Products/Defa … Id=SPM7000) - and seems more like an updated version of the older DX8, but with one less channel). I bound the radio to the receiver and satellite first and then plugged the satellite into the PixHawk. I can manipulate the green bars on the radio calibration screen, but i do not see the min and max red lines as i see in the instructions (i am using APM on a mac).

i am a little worried that because i am using the new DX7 it may not be supported - however the AR8000 is not new and does receive the DX7 signal.

thanks for any assistance anyone can offer.

this is solved. see a parallel post in APM: Copter >> 3.1 here: viewtopic.php?f=25&t=11823&p=31417