Pixhawk booting more than 5 minutes and error: pre arm logging failed

My Pixhawk is booting sometimes more then 5minutes and sometimes the sound is the: New Io board firmware successfully loaded and sometimes there is no sound. If it is booted and I want to arm I get the error: AP logger:Stuck thread write or pre arm logging failed.
Also the Mavlink console is not working on Arducopter but it works on Px4.
I have an Pixhawk 1 clone without the 1mb limit.
I tried resetting the Pixhawk. I tried an older version of Ardupilot and flashing px4 where I also get errors like avionics power low 4.9 v Wich is right but nothing to worry about (in ardupilot the limit is much lower and I never got a warning)(I like ardupilot more because it is flying much better so I want to use Ardupilot). next step is to reflash everything but I don’t know how to do it (I’m still not sure which pin is boot pin 0 and Wich Programm is the best to flash it).
Is there an easier way to flash it or should i flash it?. Why am I getting so many errors? is it normal to get so many errors? if not I have no problems buying a new Pixhawk. I looked at the 2.48 Pixhawk clones. are they good or is there a better cheap Pixhawk (limit is 100€)?

One easy way to flash it;

  1. Use latest version of MP.
  2. Connect Pixhawk to USB
  3. Go to “Initial Setup”
  4. if you normally use lets say Copter firmware, select Ardu plane and let MP flash it.
  5. You will be promoted that if you want to load “Chibios”, say yes.

Once its flashed with the wrong firmware, go back and now flash it with the the frame type you want to support. Typically it eliminates all mis configuration problems right away.

Thank you for your reply.
You are right flashig the wrong firmware and then the right helped
Now im just getting the logging failed message wich should be eliminated by a new Sd-Card (im curently using a realy slow noname sd card wich came with the Pixhawk) so i have ordere a SanDisk ultra 16gb wich should come tomorrow. :grinning:

UPDATE: I just ran a test of the Sd-card and i found out that this is not a 16GB card, it is an 80mb card
and the writing speed is 1mb/s.

Never use no name SD cards. They will crash your drone or plane in mid air :slight_smile:

1 Like

Bad news im still getting logging failed messages even with the new sd-card.
what can i do?

Post your parameter file, maybe there is something to see.

Here you go https://drive.google.com/open?id=1rmteulPgwfSRJhBpjf47b_HfoBNe_28E
(The forum does not take .params files so i uploaded it to google drive where you can download it)
Spoiler: They are the default parameters

Parameter files can be attached no problem, do it all the time. In fact I’ll attached one here as an example. I don’t know how you created that parameter file but the format is not friendly for review.

Sample parameters.param (18.4 KB)

I got the old file from qgroundcontroll.
Here is the new one from Missionplanner (i uploaded it with the same steps as the old one but this worked)

parameter.param (17.7 KB)

Nothing obvious. Really only looked at the LOG_BACKEND_TYPE which is at default as you said. What version of Firmware loaded? OnN the messages screen under the HUD right afterboot. fmuv2, fmuv3, Pixhawk1? Not that this would typically cause a logging failure but more info to consider maybe. How do you know it’s not a 1Mb board?

you can try BRD_SD_SLOWDOWN

I have already tried it an it made no difference.

I think I have found the solution, I just needed to format the sd-card in exfat not in fat32.
I have no Idea why becouse i have read in the internet that fat32 is better.
Do you know why?

In the MavLink Console i wrote: ver all