Pixhawk and Octocopter

I think the gods are against me as the board just threw away my first post so lets hope this is OK.

I am installing a Pixhawk on an Octocopter that was using an APM + Oilpan. (As well as the Octo I have a quad and a 'plane using APM’s so think I am reasonably experienced - I am using Win7).

The first problem was that Mission Planner has not been used for some time and updated itself and then permanently screwed itself so that it had to be deleted. It was not the fully installed version.

The next problem was that I did not realise that I had to use the MP Installer so that I had the right drivers. Previously I ran MP from a folder

So on to version 1.2.92 of MP and I successfully uploaded the Octo firmware to my Pixhawk. I wanted to complete the first time installation ‘manually’ and not use the Wizard but that is not an option. So on to the Wizard which checked I had the right firmware for an Octo and after I had selected the COM port it connected and I started the config process. Sadly it only offers me Quads for the 'copter configuration. Where is the Octo config?

As I could not use that version of MP I decided to try ver 2 and on to Initial Setup again. Only two options - 3DR Radio and Install Firmware. Selected the latter, it checked I had the correct version but then offers me nothing further from that screen. No config options nothing.

I hope someone can help me.


No, you deleted the post yourself at 1815h UTC. It was originally posted to the PX4 forums and titled “Octocopter and PX4” :slight_smile:.

Sorry not used to this board and now I’ve pressed the Accept Answer by mistake.

The first post I wrote did not appear after I had clicked to post it. I searched and tried View Your Posts but I still registered 0 posts so I decided to do a second post in the Pixhawk forum rather than PX4. When I had finished and posted and Viewed my Posts I found the first one had now appeared so deleted it.


The first 2 posts of every new user have to be approved by moderators to mitigate spam, as it is explained in the forum rules which you have to accept when registering :slight_smile:.

I set the topic back to “unsolved”.

Decided to try again with MP1.2.92 and this time the First Time Setup Wizard offered me to select the type of craft I am using (Octo). A later option screen to set the orientation of the craft (x or +) it only offered me quad versions but I decided to select a + quad as this was the nearest. All this came after a complete PC reset.

The manual doesn’t mention the Wizard and shows a different set of screen shots.


As far as I understand, the Wizard is brand new. To find out more about it, you should ask in the Mission Planner subforum. Anyways, when it comes to Plus or X configuration, it didn’t offer you Quad versions. The symbol pictures which explain the difference between Plus and X configuration are just Quads, but it’s still an Octo Plus or X when you selected Octo before. The question is if your Octo is a Plus. Plus is nowadays a rather unusual configuration. It won’t make your Octo crash but it might fly slightly different than you expect if you select the “wrong” configuration.

I have tried to fly a quad as an X when after setting it up as a plus and you are right it is very strange.

My Octo is a + and I should be able to test it tomorrow when I receive a new GPS.