Pixhawk 4 mini radio input problems?

I’m trying to run Arducopter in Mission Planner on a Pixhawk 4 mini. I got PX4 firmware to run on the mini in Q Ground Control so I think that means my hardware and wiring are good. Taranis X9D+ SE, Archer R10 Pro Receiver, Holybro Pixhawk 4 mini, Micro Power Module (PM06 v2), and Neo-M8N GPS. I open Mission Planner and navigate to Install Firmware. I choose Load custom firmware and choose: arducopter.apj from ArduPilot firmware : /Copter/stable-4.1.2/PH4-mini. When Upload Done I CONNECT to the MAVlink COM Port with 115200 (USB Cable). The DATA Displays all work as expected when I move the mini around, I navigate to SETUP and Accel Calibration seems to work fine. Radio Calibration is driving me nuts!!! I’ve been at this for over a week, I get green bars in Mission Planner and I can run Radio Calibration but when I disconnect USB then reconnect USB the green bars no longer respond to radio inputs. I’ve run out of ideas, any insights would be greatly appreciated. It’s not like I’m new to Mission Planner, I have a regular Pixhawk 4 that I got to run flawlessly from Mission Planner but the mini is driving me insane???

how are you powering the flight controller?

I’m powering the flight controller with USB from my Windows PC.

have you not tested it powered from something other than usb? I think thats a long range receiver and could too powerful to run from usb. how close is your transmitter to the receiver, frsky receviers tend to cut out if the transmitter is too close.

I have tried to power the system with the Pixhawk power module and that doesn’t make any difference.

I appreciate your suggestions, I’m desperate and willing to try anything. Maybe my problem is tunnel vision but here’s the thing, it all worked in Q Ground Control with the exact same hardware setup. Power from USB worked and it didn’t matter how close the transmitter and receiver were.

what port on the receiver are you using? are you using Sbus or F.Port

its possible its a bug in recent firmware try and older version of ardupilot or set RC_PROTOCOLS to 3 to force SBUS detection.

I plugged the receiver into the S.bus Out slot, there is no F.Port slot on the receiver is there? I have seen the choice of S.Port or F.port on the transmitter as options when I bind, I have tried both and neither seem to make a difference.

You Are The Man!!!

4.0.7 looks like the real deal : ) I have to shake the cobwebs out of my head and start from scratch in the morning because I have no idea how much craziness that I have tried that could possibly haunt me in up the air.

I really appreciate your patience and you hanging in there with me, Thank You!

Reset to defaults then do the Initial Parameters in MissionPlanner, Setup

No, I do not think 4.0.7 is the solution. I think the solution is 4.1.2 and set RC_PROTOCOLS to 8 (not 3!!) to force SBUS detection.

I loaded 4.1.2 and changed RC_PROTOCOLS from 1 to 8 and the Radio Calibration displays would not respond to transmitter stick adjustments.

Thanks for testing that out. Please do report a bug on github

says 3 here

The parameter is a bitmask. It says 3rd bit. and 2 to the power of 3 is 8.
Basically when you only activate the 3rd bit on a binary word, the decimal number will be 8

1 Like

I did see that SBUS was the only boxed that was checked in the protocols when I switched RC_PROTOCOLS from 1 to 8. It just didn’t help solve the Radio Stick display problem in Mission Planner like loading 4.0.7 did.

But you did fully power down the entire system and did a full cold start after changing that parameter right?

I know it’s not exactly the same, but I had no issues with upgrade to 4.1.2 for FMUv2 (pixfalcon), FMUv3 (pixhawk 2.4.8) and FMUv5 (V5 nano) - all using SBUS for RC control.

I also run 4.1.0 and 4.1.1copters with SBUS on CubeBlack, CubeOrange and Pixhawk4 with no troubles.
But again that is not a Pixhawk4mini

“But you did fully power down the entire system and did a full cold start after changing that parameter right?” I couldn’t remember so I ran the following sequence:

Loaded 4.1.2 Mission Planner again.
Connected to MAVLink Port; CONFIG Tab.
Full Parameter List.
Reset to default.
Write Params.
Shut everything down including Radio, MP, and unplugged USB.
Restarted everything, Radio, MP and plugged in USB.
Changed RC_PROTOCOLS from 1 to 8, observed SBUS was only protocol checked.
Shut everything down again including Radio, MP, and unplugged USB.
Restarted everything, Radio, MP and plugged in USB.
Connected to MAVLink Port; SETUP Tab; Radio Calibration.
Radio Calibration displays do not respond to transmitter stick adjustments.

I’ll try anything that you guys suggest but when I go back to 4.0.7 the problem goes away no matter what components I start and restart.