Servers by jDrones

Pixhawk 4, BLHELI_S rev16 ESCs, ArduCopter V3.6.4 - Failure to Calibrate ESCs, Motors will not spin

pixhawk4

(Jesse) #6

Thank you. I have felt like I was missing something throughout this whole issue diagnosing process. Your comment made me go back to square 1 and reread the manual. I found that I have it connected all wrong. The Pixhawk 4 came with breakouts for the I/O PWM OUT port which I missed when I was unboxing it. As a result, I thought there was nowhere to plug in the ESC connectors if using the I/O. I am going to redo everything now and see how it goes. I will report back with pictures and results.


(Jesse) #7

The ESCs were also giving me issues. They would not connect to any of the BLHELI software, probably because they were connected completely incorrectly. I think once I get it hooked up right my problems will be fixed.

Thank you both for the help.


(Dave) #8

If you mean via passthrough it should work but you have to set a parameter(s). Check the Wiki here:
http://ardupilot.org/copter/docs/common-frsky-passthrough.html

To James point you have to decide if you are going to use Dshot or PWM. If Dshot then you need to use those FMU outputs and configure your motor outputs on channels 9-12. If PWM then the I/O outputs will be fine with default channel config. I wonder if those ESC’s are flashed for Dshot though. The HK website says “can be flashed” so it might not work. Worth trying though.


(Staelens peter) #9

Hello everybody,
I’m in the process of building my first hexa copter. All calibration worked fine but when the engines are powered the problems occurred. They spin normally and the ground station tells me that the copter is armed. No problem so far. Whenever I try to raise my throttle speed several motors stop and others are running at a reduced or higher speed depending on the attempt. My first idea was the esc calibration. However this procedure is not working for me. After starting up with throttle max and power on / off and on again the APM should report me that the esc are in calibration mode. This does not happen. I have a pixhawk 4 and multirotor arducopter soft 3.6.4 running downloaded via QGround control. I was able to perform a first flight in the past but it seems after downloading the default values in the pixhawk and downloading the latest arducopter software that the problems started. I have simonk 30A esc and 2312 920KV brushless engines. The reciever is a X8R connected via SBUS to the pixhawk. The engines are connected to the main 1 till 6 outputs. Radio calibration, accelerometer and compass calibration have been performed without any problem. I have retrieved the full parameter list out of my pixhawk and I think that something is wrong there. Can someone help me? Thanks Peter Belgiumparameter list.param (14.1 KB)


(Dave) #10

Do you actually have a + type Hexa as your parameter file shows? That’s uncommon, X is typical. FRAME_TYPE parameter.


(Staelens peter) #11

Dave, I have engine 1 on the top and its labeled with the yellow tag. Left you have then engine 5 and right 4 etc…See pictures in word document


(Jesse) #12

I am likely going to go with DShot, assuming I can get passthrough to work properly.

After all of the diagnosing and then finding my issue here, I have found that one of my ESCs is bad. 3 calibrate without issue, 1 refuses to calibrate (even when I try to do it manually by plugging it directly into the receiver).

So once HobbyKing gets the replacement to me I should be up and running.

Also, when running DShot, is there anything special I need to do setup wise aside from connecting my ESCs to the FMU-PWM-out on the Power Management board?


(Dave) #13

Peter-OK, then you have it right for a Hex +. Not sure what your problem is.


(Dave) #14

You need to re-assign the motor outputs to SERVO9_FUNCTION (33) thru SERVO12_FUNCTION (36). Defaults are on 1-4 using the main outs.
Then set MOT_PWM_TYPE to Dshot150 (4)


(Staelens peter) #15

Dave,
Not sure what you are talking about. Are these settings in mission planner or were can I set these servo settings. I have 6 main outputs so i think servo9 till 14? I have another idea that popped up last night. I had no problem with my drone before I have bounded my X8R in another way. At first I had my sbus and 8 channels. These 8 channels are the sbus channels. If I would love to use the channels on the X8R for my gimball I have rebounded it with 2 switches, I think you wil know the procedure. After that I had 16 channels were 8 could be used on the X8R itself. My gimball worked fine. After this I haven’t armed my drone anymore and when I did it didn’t work anymore. Do you know if this has something to do with my problem.
Calibrating the ESC should result in a max PWM to the ESC. Do you know the relation between channel 3 ( were the throttle is) and the main outputs on my pixhawk. I think if I will measure with a scope on my PWM outputs they will not change. Is this done via the servo - fucntion? Thanks in advance for your help.


(James Pattison) #16

They’re in missionplanner. You also need to set brd_pwm_count to 6, and set relay_pin and relay_pin2 to -1.
Aux 5 & 6 default to being relay pins not motor outputs.


(Dave) #17

Peter-There are 2 topics going in this thread since you introduced yours and I was responding to Jesse in regards to the Servo outputs.

With the X8R you will get 16 chanells from Sbus (assuming that’s what you selected in hardware setup) and also channels 1-8 on the PWM outputs. This is with no jumpers on Bind. A more tpyical configuration is to have chanells 9-16 on the PWM outputs which is enabled by jumping the signal pins of Chan 1&2 and Chan 3&4 then bind. Refer to your X8R manual for this.


(Jesse) #18

Thanks Dave. I have not yet switched to DShot. I really wanted to get it working before trying to make changes to ESC settings.

I am almost ready for my first flight, but need to switch the direction of two of my motors. I want to do that via changing ESC parameters.

Unfortunately, I cannot get the ESCs to be read by the BLHELI computer software. I have SERVO_BLH_AUTO set to 1, but when I click “read setup” I get an error that says unable to connect to ESC #1.

I also tried using the google chrome blheli-configurator app and when I click “read setup” there, it just says “finished” but nothing else happens and the read, write, and other buttons stay greyed out.

Any ideas on what could be causing that issue?


(Dave) #19

Which outputs are you on now? This shouldn’t really matter as the “auto” parameter should map them all but just curious. Using BLHelisuite 16 not 32 and you have battery power to the ESC before selecting read setup?


(Jesse) #20

I am on the I/O outputs (1 through 4). I am using “BLHeliSuite 16.7.14.9.0.1” and I do have the battery connected before clicking read setup.


(Dave) #21

OK try adding “15” to the SERVO_BLH_MASK parameter. This is the bitmask for manually setting chan 1-4 to BLHeli. I have not had to do this but I have seen several posts where people have claimed it has worked. I’m not sure if you also need the Auto parameter enabled, try it both ways.


(Jesse) #22

I tried it both ways and am still getting the same errors. First, I get this:

Then, once I click “OK”, this message pops up:

If I then try repeatedly I only get the second message.

This is all being done with the battery fully charged and connected.


(Dave) #23

Almost out of ideas. How did you install the firmware to your Pixhawk 4? If you allowed Mission planner to select the version maybe you can try installing it directly from the firmware repository instead using the “load custom firmware” option. Of course it’s not custom firmware but I have read so many posts about issues with the Pixhawk 4 that maybe MP is not auto detecting it correctly. There are definitely FC’s where this is true I’m just not sure about the Pixhawk 4. In any case if it’s the same no harm done. Firmware here:
http://firmware.ardupilot.org/Copter/stable/Pixhawk4/


(Jesse) #24

I just did the setup through mission planner. I will give that a try and report back. Thank you for the help.


(Jesse) #25

I tried this as well and it still did not work. Same exact messages that I posted earlier. So, I guess no DShot for me. I gave up and just switched two wires to reverse the motor direction on the 2 motors that needed to be changed. Thank you both for all of the help, I really appreciate it.