Pixhawk 4 arducopter not working

Hello, I’m trying to use my holybro pixhawk 4 with the latest arducopter firmware but I’m unable to make it work correctly. The pixhawk will work correctly using Px4 firmware via QGC and I’m able to complete the setup with no problems, including the sensors calibration. I’m trying to upload the latest arducopter firmware using the method showed by painless360 by downloading it and changing the name to arducopter.px4, and then loading it using the upload custom firmware with QGC. When this process is finished the FMU B/E led will star flashing red and the external magnetometer wont calibrate (using MP), also in the messages there is one that says that there is a firmware problem. I thinks there is no problem with the hardware and connections as it works just fine with Px4 and QGC, but wont work with arducopter and MP. I don’t know what to do and I prefer using arducopter rather than Px4, please help!

Just use QGC to flash Arducopter directly. Choose Board type as Pixhawk4.

QGC

Alternatively use the .apj file from here and use Mission planner to flash “custom firmware”.
https://firmware.ardupilot.org/Copter/stable/Pixhawk4/

Thanks, so I just tried what you suggested but still same issue.
image

I will try the “custom firmware” method again without changing its name and I will come back to you, thanks!

I don’t see anything wrong. It looks like an unconfigured Flight Controller to me. Use Mission Planner going forward to configure and calibrate it if you are sticking with Ardupilot.

The problem is that the external magnetometer wont calibrate and the B/E FMU light will always flash red only when using Arducopter, I already tryied a couple of times doing the sensor calibration but still with no luck with the magnetometer, on the other hand using Px4 there is no problem when calibrating the magnetometer. Now I’m trying to upload the firmware with MP, connecting the Pixhawk with a usb cable but MP will not let me upload it as it says that I’m connected via Mavlink.

ok never mind on that last thing, I forgot I had to disconnect it to upload the firmware. So I tried the custom firmware method but it says that the firmware is already there. So still no luck

That looks correct how it is in the messages screen, all those red lines are expected before configuration.

Have you first selected the frame type, like quad X, hex X, or Y6 and so on ?
Then run through the sensors calibration and show us what it looks like then.

So I already did, radio, accel, frame type, and compass calibration. I still have the red FMU B/E led flashing, the pixhawk led is flashing in yellow, and I have the following messages.

Capture 3

I have tried the compass calibration over and over again, outside, with a lower fitness but still the Mag 1 wont calibrate

deselect these: Use Compass2 and Use Compass3
so you only have Use Compass1 and it should be the external one.

Go outside, wait for good GPS 3D fix, then run the compass cal

Ok will do, ill come back in 30 min

So I’m here outside and just tried what you told me, still no luck, the green bar will just go to the left over and over again. I have 13 sats so I think its good enough for the GPS 3D fix. :frowning:

You don’t need any fix to calibrate the compass. Now that you have actually configured everything post your parameter file. Which GPS/compass module is this?

Also just tried with relaxed fitness with no luck

Sorry what do you mean with the parameter file? What should I do to show it to you? I’m using the Holybro Pixhawk4 GPS module http://www.holybro.com/product/pixhawk-4-gps-module/ , the one that comes with the X500 pixhawk 4 kit

Well, forget that for now then. How about a couple photo’s of this craft showing the Flight Controller and the GPS module.

Here you go. By the way thanks for your time and your help, I really appreciate it.

OK, nice looking craft. Back to the Parameter file. Connect to Mission Planner go to Config>Full Parameter List and on the right side press the Save To File button. Attached that file here.

How are you doing the Compass cal? Spinning it around on all axis?

Thanks!

Full parameter list.param (17.7 KB)

Yes sir, I spin the copter facing all of the different direction, as its instructed in the Compass Calibration instructions of ardupilot webpage.