Pixhawk 2.4.8 throttle problems

Hi all,
few years ago I built a DJI F450, ESC DJI 420 lite, motors DJI 2312e, GPS Ralink SE 100, radio Flysky FS-i6x, receiver Flysky FS-i10ab, FC APM 2.8.

Recently I bought Pixhawk 2.4.8, looks OK, compass calibrated, GPS signal is good (about 15 sats) I can arm and motor start to spin.
Problem is that I noticed during the configuration in mission planner that motors reach max power when throttle is on half, trying to move pitch or roll to max mission planner is giving error “crashed, disarmed”.
I run again radio calibration, all value looks OK (between about 1000 to 2000), on mission planner all channels looks calibrated.
I read that my ESC cannot be calibrated, anyhow I tried ESC calibration procedure, after the calibration (but still in calibration mode) throttle is OK but restarting the Pixhawk i normal mode again max power on half throttle.

Pixhawk is running latest firmware but I tried also with old version, I tried with receiver connected in PPM or sbus.

I tried to set below parameters but same problem:


Regards Mario

hi @fellymar
could you please send .BIN log file ?

Hi, was there any resolve to this? I have the same issue and cannot find a fix. Many thanks.

Are you running this on the bench w/o props?

Yes I am running without props on the bench since the last time I tried to fly last weekend. I’ll try to get in the air again on Saturday it’s earliest I’ll get time unfortunately. I found two old threads on this exact issue so it does exist for others but I’m not sure how any of them were resolved. I was hoping I’d get some answer from anyone that might have had this issue direct and maybe eliminate another thing off the list. I will, as above, give it a go on Saturday and will post the flight log when I do to see if some data can be useful.

It might not be an issue at all. Did you run the motors in Mission Planners Motor Test up to 100% and did they continue to increase in speed as you increased the throttle percentage? This won’t happen on the bench using the transmitter in any flight mode.The motors may speed up, slow down, act randomly.

I hear ya, I’ll try again hopefully Saturday and see how I go. The reason I think it’s still an issue is that when I calibrate the motors they react to 0-100% throttle range. Motor test I believe run up to 100% when I test but it’s hard to say for sure. How would I find out if they run 0-100% in a motor test, is there anywhere I can see a measurement and the expected rpm at 100%?

The reason I think this is still an issue is I’ve bench tested way back when the drone actually worked and in some flight modes such as acro mode I had full throttle range some of the time, motors modulate but I was confident I had full throttle range, now no matter when or what I do I only have 0-50% range on transmitter. The problem that creates is when I try to control the range its so tight that if the drone flies a bit high and you want to get get back down when you move the throttle the slightest bit the drone drops out of the sky because it’s such a large change on the motors.

Will try again, as I’m running out of ideas/options and will post the log to see if anything can be taken from it.

No, not unless you have ESC Telemetry.

I don’t understand what you are saying here. On Mission planners Radio calibration screen does throttle go full range?

Yes it does but when I fly and I take off and try to hover I can’t because the slightest change on the throttle the drone just shoots up then when I try to and drop the throttle even the slightest change is enough to bring the drone down at a rapid pace and then crash, it’s definitely not my flying skills… before this issue arose I used to easily hover at about 40% throttle in any mode but mainly stabilise. Loiter used to work a dream for me but now when I switch to loiter, given I can only get about 2 metres off the ground the drone lands, hard. I’m presuming that’s related because it can’t find a sweet spot throttle and as I’m not using RTK it’s going to drift, when the barometer detects ground it just lands.

Hi Maybe there is no problem with ESC or radio … You do not write what version of AC you have uploaded. Maybe you have bad pidy copter aggressively reacts to data from accelerometer. Publish at least PARAM file, maybe someone will find something. sometime inadvertently in the old version of AC, the ALThold pid appeared instead of 1 to 300 and in althold I had exactly as you describe, but in stabilize it was ok. I do not know ESC that is not calibrated for PWM or oneshot. Maybe you could also describe what protocol you have and what protocol you have activated…