Pixhawk 2.4.8 and esc calibration

I am totally new to uav field. I have just started working on it. We have a pixhawk 2.4.8 flight controller and simonk esc. I am following all the steps for calibration as mentioned on the website like RC,ESC, compas,etc. ESC calibration i am doing with all at once method. But when i arm the copter and give throttle. The motors are not rotating at the same speed as i can see i the graph . I tried calibrating multiple times but same issue is coming. Is there anything else i need to check which might be causing this issue of all motors running at different speeds.?? Any help is appreciated.

Remove the props and use Mission Planners Motor Test function to determine if the motors are rotating at the same speed with respect to throttle. Any other bench test method will not tell you this.

Thanks for quick reply dave. We tried using motor test . All the motors are runnning but whethee at same rpm or. not i am not able to make out.
After calibration when i use throttle to run the motors a graph comes in mission planner which shows the speed of all the motors being different. I want to know how to solve this.

They won’t run at the same speed sitting on the bench. What you are describing is normal. Assuming you have done all the mandatory calibrations and set the initial tuning parameters put props on it get off the bench and fly it.