Pixhawk 2.4.6 and MaxSonar-EZ0 (in front)

I’m having a problem on my quad I’m using a pixhawk 2.4.6 and a sonar MaxSonar-EZ0, the sonar is IN FRONT OF THE QUAD …
I would like to know which parameter I change in the pixhawk (using mission planner or similar), when the sonar detects object the quad stops or has another attitude.

The quad had a standard attitude that increased the throttle but after an upgrade he lost this attitude.

I installed the sonar and changed the parameters with the help of the link: http://ardupilot.org/copter/docs/common-rangefinder-maxbotix-analog.html


Is this on a Rover or quadcopter?

Thanks, Grant.

this is a quadcopter, this attitude is during fly

I’ll move it to the quadcopter section then.

Thanks, Grant.

tanks so much my friend
i am sorry, i dont speak a good english

What version of the Copter software are you running? Do you have a dataflash log you can attach? Below are the instructions you need to follow for connecting the sonar.


Thanks, Grant.

I’ve just checked and the functionality of stopping if something has been detected via a sonar has only just been put into Master. It should be available in the next Beta which is AC3.5-rc2 available later this week. We would love it if you tested this out for us and got back to us with your results. Note however this is beta testing so you must be very confident with your configuration and ability to handle your drone if something goes wrong.

Thanks, Grant.

I am using version APM:Copter v3.3.3(acf2e10c) thats correct?
And I use a mission planner version build .1.1.6267.39040

I update to the version AC3.5-rc2 using the mission planner? on help tab and after click “Check for beta updates”?

I will definitely test and release the tests here!
If the way of updating that I said is not certain.
Would you have another way to upgrade to this beta version(AC3.5-rc2)?

Now I know how to install custom firmware using mission planner, but where can I download AC3.5-rc2 when launching?

You need to click on the beta firmware button in Mission Planner. Its in the same area as the custom firmware button.

Thanks, Grant.

yes i see, i wating the AC3.5-rc2, tanks so much

now I am use V3.5-rc1… but I dont see any parameter for sonar… i think i be wating the AC3.5-rc2