Servers by jDrones

Pixhawk 2.1 Cube won't take compass calibration

(professor churl) #1


I have a Pixhawk 2.1 Standard which seemingly will not accept compass calibration i.e. even if the calibration procedure is completed, it will not arm either immediate after calibration or after power cycle, with the ‘compass not calibrated’ error.

The unit has no external modules or connected add-ons except the piezo buzzer. Power is derived from the current sensor out of the box. I’m using APM Planner 2.0, since Mission Planner seemed to conflict with the .NET Framework installed on my computer at the time.

Here’s some screenshots of the compass screen showing first the usual calibration offsets I get, then 2nd when I tried disabling the compass, then when i attempted a calibration outside away from the metal of the building and my machine shop.

The outside calibration did not change the offsets appreciably. The Compass 1 offsets seem to be way out of accepted bounds according to the APM Planner and Mission Planner guides.

Insight on this issue would be appreciated. This unit was purchased on Amazon at this link not long ago and is pretty much straight out of the box.

(Hunt0r) #2

I have had compass problems when my plane has magnets, for example to hold a canopy on. Are there perhaps any magnets nearby?

(professor churl) #3

So to update - this issue was resolved by using Mission Planner to upload the firmware and perform all calibrations from scratch. It seems like APM does not play well with the Pixhawk 2.1 for some reason.