Pixhawk 2.1 Cube only works when connected to a computer via USB

I have a problem with my Pixhawk 2.1
When I connect it to a computer (not mission planner) it works. I get green lights. When I connect the battery, the motors work, but as soon as I disconnect it from the computer it goes to a yellow light and I have to control over the speed of the motors. I have to disconnect the battery to stop it. There is also a loud alarm when only the battery is connected. Does anyone have an idea as to what might be wrong? If required, I can make a video of what is going on.

Thanks for reading,

The alarm is telling you that the battery FS has been triggered.
After that FS it will go into whatever mode you set in the parameters.
So check your battery FS values, and make sure you have calibrated your battery monitor.

Thank you, that worked. I just don’t know how to calibrate the monitor.
The only problem that remains is that I have to connect the Pixhawk to USB power in order to power on the Here GPS.
As soon as the GPS lights come on, I can remove the USB power and it works.

You will find the instruction for battery monitor calibration Here:

It sounds like the startup current drain for the Here GPS is exceeding the capacity of the power module BEC.
What type of power module do you have?
Does it have an integral BEC or are you using an external BEC?

Thank you for the info.
I have the module that came with the Cube. It has the yellow connectors on the ends. I’m not sure about the BEC. I’m using BH_Heli 40a ESC’s that are tied into a power distribution board.
I’m worried right now that if I try to fly it, it will just crash or gain altitude fast at a low input.

So does everything power up ok from the battery if the GPS is disconnected from the Cube?

First step is always to isolate what component is causing the issue then focus an that component.
If the system is fine until you plug the GPS into the Cube, then look at the power lead for the GPS.
It doesn’t HAVE to come from the Cube, although it should not be a problem normally.
Maybe a faulty Here GPS?
If you can isolate the power lead and connect a multimeter in line and measure the current required to start it, that might be a starting point.

Everything powers up when on USB and Battery, then if I disconnect the USB, all stays powered up. It’s only when I try with battery only. I can even use a USB wall charger, it doesn’t have to be a computer.
I’m using two GPS units. I’ve tried only 1 GPS and it does the same thing. But other than GPS, everything powers up by battery. I’ll keep digging…

I’ve just encountered another problem. When the motors are armed and spinning, it’s normal for them to stop after 10 seconds. But I gave it 1/4 throttle and full stick forward, and the motors stopped. The throttle was still at 1/4-1/3.
Is it possible that the front motors slowed down to idle speed and stopped the throttle?

I just did some more testing. If I give any input while the motors are at 50% throttle and hold that input, the motors stop very quickly. I’m concerned that this thing is going to fall from the sky…

Could this be because it’s stationary and the accelerometer is not sensing movement?

With a log file we would be able to tell you more.

I’m sorry. I don’t know how to get a log file.

Is there some sort of manual that covers all copter issues?
I figure there should be a 100 pg procedure.

The manual is here
And it is probably more than 100 pages.

Great, thank you! I really appreciate the help!
I’ll post results when I get them.

Is there an easy way to grab a log file from the PX2.1?

The instructions for the Data Flash Logs is here

40 1-15-2018 3-46-56 PM.bin (368.6 KB)

Here is the most recent log file.

Thanks for the instructions!

Regarding the motors stopping when you give input:

This may be because the flight controller thinks it has crashed. The FC doesn’t know that you’re bench testing the copter, so it assumes that it is supposed to be flying. When you give inputs, the FC will command the motors to respond to your input, but because it is sitting on your bench, it won’t detect a change in attitude, so it thinks it crashed and disarms itself. If you have Mission Planner connected at the time, it will tell you why the copter disarmed.

Regarding the GPS power: when you say that the GPS does not power on, do you mean that the LED’s don’t light up? Does the Pixhawk detect the GPS? I ask because I’ve had a few situations where the GPS LED’s don’t work properly, but the GPS/compass are functioning.

That makes a lot of sense (thinks it’s crashed).
The lights on the GPS are now coming on with only battery connect, thank you for your help.
I have two HERE GPS units installed. connected to GPS 2.
The lights on that one don’t come on, but I think it’s because the two wires for the Arm button are not connected. How would I be able to tell if the second unit is working? I have a third HERE, and was going to connect it to Telemetry 2 port, but I’m not sure if it supports a third GPS yet.


Could you say more about “I’ve had a few situations where the GPS LED’s don’t work properly, but the GPS/compass are functioning”.

Did you find solution(s) to that?



Firstly, the status LEDs won’t work if it’s plugged into GPS2 port (or any port except GPS1).

Also, the status LED output is also available through the port labeled USB, and if I recall correctly, it may have some interaction if you have an external LED connected there.

Besides that, the situations I mentioned were unusual cases where I was dealing with a noisy power source and experimentally powering the Pixhawk in a non-standard way. For some reason, the status LEDs would sometimes die when noisy power was introduced momentarily, but operation was normal. I was never able to root cause the issue, but I don’t expect other people would run into it in the same way I did.