Pixhack 2.8.4 and chibios problems

Is Pixhack 2.8.4 (FMUv2) compatible with Chibios?
When loading the ChibiOS version of Heli 3.6-RC7 from QGC I get the following errors:
Firmware file missing parameter_xml_size key
Firmware file missing airframe_xml_size key
After that the fw update finishes but QGC can’t connect to the Pixhack.
Tried MP and it connects and gets the parameters Ok.
But I miss the heli setup page from QGC.

Loading back the Nuttx version and everything seems Ok in QGC and MP.
Is there anything I could try or should I stick with the Nuttx version?

As far as I knew it should be compatible. But obviously if it works fine with NuttX and not with ChibiOS there is a problem. I think as long as it appears to work fine with NuttX I’d stick with that for right now. I’ll look into this with the fmuv2 boards and see if I can re-produce the issue.

Thx Chris,

I will stick with NuttX for now.

I have it running ChibiOS rover so it might be a problem with copter code.

Actually, in my testing, I have tried uploading the rover FW and got the same behavior.

Sorry, read incorrectly. I have no-name Pixhawk, not a PixHACK. Maybe different hardware…