Pitch and roll twitch in loiter (Adjust Gain)

Is it common for the control inputs in pitch and roll to be a little twitchy in loiter mode? In STD mode the craft is smooth and flowing. A better question is can gain be adjusted for modes separately for pitch and roll to calm shakes? It seems like it needs to be lowered for loiter mode. Thanks…

No luck… If I figure it out I’ll post it here. We need some more action on this forum.

I’m new at this as well, but that seems to be the nature of loiter mode. It wants to stay in one place but you can push it around with the pitch/roll input. You might want to try PosHold mode. It flies like in AltHold. That may be what you’re looking for. copter.ardupilot.com/wiki/poshold-mode/

Hey…this sounds like what I’m looking for. There are so many options with the Pixhawk…one of the reasons why I chose the 3DR. Thank you!

Wow…this is easier said than done…after working with the radio most of the day and trying to use a tutorial here that didn’t work I managed to activate/assign as switch to Ch8 in the radio on my own. Now the trick is to assign a flight mode to that switch but other the modes need to be activated. So I’m stuck until I figure that out.

I posted instruction here communistech.com/how-to-conf … iris-quad/

Thank you for that. Great work. I got that all set up for Ch8 but I’m guessing you can’t assign a flight mode to that channel and only the options allowed in mission planner. So I think I have to replace loiter mode with position hold. What I was trying to do was put position hold on Ch8 and leave loiter mode on its own switch with STD and Auto. I wonder if that is possible.

Also, it seem as though my radio doesn’t have that nice menu with edit, insert, copy, move delete. I have to press menu and highlight what I want moved and press down. Maybe they changed the firmware.

I don’t think you can put a flight mode on ch8. You can use it for toggling simple and super simple mode though. You will need to set it in the flight modes in mission planner. The way they setup the radio is was kind of nice. The RTL switch actually toggles the modes selected by the mode switch (I know, not their real names but you get what I mean). With RTL off, the mode switch selects modes 1-3. With RTL on, the mode switch selects 4-6 and all three of those modes are set to RTL flight mode by default.

So, I just changed mode 5 in MP to be PosHold. Now when I fly I can put the mode switch in the center position and use the RTL switch to change between Loiter and PosHold to get a feel for the difference. If you do this though, RTL isn’t always RTL anymore, so you have to keep track of how you customize it, as you will have six modes to keep track of.

Back to the original question, I think that the answer is that: Yes, it is the nature on LTR mode to twitch. In LTR mode the IRIS (I think) is using GPS to maintain its position. According to the manual the GPS is updating its position information five times a second (most consumer GPS update every second). Because of the enormous complexity of calculating a position from VERY precisely timed signals from multiple very distant satellites every consumer GPS I have ever seen tends to stutter around in its position readout, usually just a few feet. If IRIS is trying to adjust to this 5 Hz update cycle it is bound to twitch a little. As an engineer, I never cease to be amazed at GPS technology.

Personally, I set mine up as
1 stab
2 alt hold
3 loiter
4 auto
5 of loiter
6 land

With rtl on failsafe and a switch for throttle cut (set such that it triggers the failsafe obviously…
left side of the controller both switches up is loiter, down is land. … all on proved label at the top of my remote. … and switches together is stab for takeoff and landing.

Thanks for the great replies guys. I have to agree that with the GPS loiter mode on causing twitch. it makes sense that updating from the pixhawk every so many seconds and then inputting your own control is going to account for some of the nervous twitch.
I replaced loiter mode with position hold and tested it tonight. It’s great. The inputs are much more natural as described. I noticed almost no nervousness at all. I’m going to leave that flight mode in place. I appears to lock in just as well (in place) as loiter. The transition from moving back to hold is excellent.
As far as Ch8 goes I’ll still have to figure out how to assign a fight mode. For now I’ll save it for the other features like tuning or super/simple mode ect.
At least my twitching is non issue now and that was my goal to get rig of that. If I figure out how to assign actual flight modes to channel 8 I’ll share how I did it.

You cannot put a flight mode itself on a 2pos stick through Ardupilot. But you can make it so that a 2 pos switch in OpenTX (Er9x RC SW) will override the 3pos switch and set a particular flight mode. Ie. if you have pos-hold has flight mode 5. A PWM between 1621-1749, you can set the switch to output that when enabled.

I have done a similar thing where two different switches trigger the same channel to RTL.

PS: Do you have Optical Flow Sensor?

Interesting. I’ll have to try that work-around. I’m not familiar with opentx. Are there any good resources to read up on this. Programming this radio is a mystery to me. I wish there was some documentation.

The other thing I was wondering about is setting a throttle hold. On my helicopters, I always have a throttle hold dedicated channel for emergencies or a crash. I hate the thought of a situation/crash and not being able to immediately shut off power to the motors.

My Iris is in stock configuration with the exception of pos. hold replacing loiter a and ch8 activated. I’ve not looked into the optical flow sensor. Thanks!

I wanted to report back on my experience with position hold. I’ve had a chance to really get out and fly around to check the behavior. I do still see a weird twitch here and there. Mostly I see it in roll input. I still like the smooth transition back to center stick with roll and pitch. I’m going to leave it for now.

On a positive note, I have several hours of flight time in most time being in STD and Loiter. It’s a real forgiving flier…relaxing to fly coming off high strung 3d helis. Keeping orientation I’ll have to say is more of a challenge at distance.

I’m going to figure at this point that the twitching is normal. Perhaps because of what was already mentioned. I don’t care for it, and was why I asked about it to begin with. I was hoping for some gain adjust similar to my tail holding gyros on the helis. For all I know it’s not the solution. It doesn’t get in the way of flying it safely and in control, so it is what it is for now. I’ve been in RC hobby for a long time and it always make me think …“Oh no!” glitch when you see twitching.

I think I found what I was looking for. I’ll report back when I’ve got some more flight time in. I changed my settings from default of 0.2025 on roll/pitch to 0.1884. I hope it calms the shakes. I also upped my climb sensitivity by 0.05.