PH2.1 and Edison OTG not working

I have working the APSync with the pixhawk2.1, all works perfect, except the OTG (on the go USB).

The system detects something connected (dmesg reports something conected and call OTG driver to start), but lsusb doesn’t report anything, only the two linux usb hub (always show the same).

I know that OTG give no voltage because a USB drive with LED don’t turn on. I tried with a powered USB hub, but the same, dmesg detects something connected but nothing shows on in /dev or lsusb.

I have found threads in intel edison forum, that says that to work the OTG, edison needs to be supplied with 7-15v. I try to power pixhawk2.1 with the power module, but nothing change.

Due to Edison detects the USB ID connected (with dmesg command), it’s not a hardware problem with the USB, but a software problem.

How can I use the OTG on Pixhawk2.1 with APSyng and Intel edison??

Max power is 10V btw I wouldn’t try anything higher then that.

This is a known issue I think

Unsure if the latest build has the fix rolled in yet,

Your issue sounds different since lsusb isn’t giving you any errors.

Sorry I cant help more, maybe someone else can chime in. This thread has been sitting for awhile but I am curious as eventually we are all going to run into the same problem I assume

Thank you for your answer. I also have this common problem that you share with me. But the OTG problem goes far, because I have tried removing and reconecting OTG, then is recognized with dmesg as something connected to OTG but anything more is done. I can post pictures of the error messages later. But by the moment I will use the external mini breakboard with 7-15v supply that seems to solve my problem.

Anyone have OTG working with Pixhawk2 and Edison?

hi, aleixmarto
I have the same problem, have you fixed this issue? if it’s ok, would you please tell how to fix it?

Thank you very much