Persistent EKF3 yaw inconsistent by XX degrees

Hello, I have been running into a very stubborn problem in Arduplane.

I am setting up a new plane using a Pixracer (the original from MRO, not Pixracer 2). This particular autopilot has been flying fine in a quadrotor years ago and then been sitting on the shelf since.

I flashed it with Plane 4.3.5, did accel, compass and radio calibration but kept getting “Not Ready to Arm” on Mission Planner and then “EKF3 yaw inconsistent by XX degrees” when clicking on it. After a bunch of soft and hard reboots and preflight calibrations, I gave up and tried a totally fresh Pixracer, right out of the box. I flashed it with the same firmware, uploaded the params from the original, redid the accel and compass calibrations and then got the exact same problem.

At that point, I started supspecting that perhaps something was weird with Plane 4.3.5. After all the first Pixracer had been flying fine as a copter, the second was brand new and I have had Pixracers fly in planes without any problems.

To test this, I tried older versions, this is the result:

  • Old Pixracer, plane 4.3.5 EKF3 yaw inconsistent by XX degrees.
    Also tried with EKF2, same problem.

  • New Pixracer, plane 4.3.5 same problem with params from old Pixracer and then recalibrating accels, compass.

  • New Pixracer, plane 4.34 same.

  • New Pixracer Copter 4.3.6. After accel and compass calibration, Rx connected and button pressed reports ready to arm.

  • New Pixracer, Plane 4.0.0 MP reports Ready to Arm directly after flashing from Copter. However, trying to arm gives: EKF2 Roll/Pitch inconsistent by 39 deg

  • New Pixracer, Plane 4.2.0. Did accel and compass cal. PreArm: EKF3 Roll/Pitch inconsistent by 51 deg.

  • New Pixracer, Plane 4.1.0. PreArm: EKF3 Roll/Pitch inconsistent by 51 deg

  • New Pixracer, Plane 4.0.9. MP reports Not Ready to Arm but the autopilot refuses to elaborate with:
    “Prearm checks failing
    Waiting for error messages…”
    Trying to Arm gives “EKF2 Roll/Pitch inconsistent by 39 deg”

So, plane firmwares going back all the way to 4.0.0 seem to be giving me the same problem across two different boards but only in Plane, copter seemed perfectly fine. I also looked at the gyros and mag components in the Tuning screen when spinning the vehicle on an office chair. The same component of the two different sensors (e.g. gz, gz2, mx, mx2) seemed to be tracking each other fairly well.

I am totally stumped by what’s happening. I attach a log from the “new” Pixracer running plane 4.3.5. I have armed a few times it via Force Arm on MP. Any ideas will be greatly appreciated.