PC does not detect Pixhawk PX4

Hi everyone, as I said in the title, my pc does not detect my Pixhawk when i connect it.
The pc doesn’t even do the sound when you plug something.
I apreciate all type of help.

A handful of USB leads is the first place to start.

Any LEDs show on the unit ?

Here you have a video.
You can see the LEDs, and the pc does not detect the Pixhawk.

There are 3 kinds of micro USB cables out there:
1 ) USB Charging cable
2 ) USB Data cable
3 ) USB Charging AND data cable.

If you are using #1, it will not connect.

Right.So the Pixhawk is happy.Next is different USB leads.As pmshop says there are three types.Even a charge only lead will power a Pixhawk.Even a lead that worked yesterday is suspect.

That’s right, I tried with other cable and my pc detects it, but there’s no com port on mission planner, maybe it’s drivers problem.

I connected it to QGroundControl and I have this error.
It recognises the ‘‘PX4 FMU V2’’ but again there is an error with the com port.

This worked for me. I tried skull candy headphone charger, did not work. I used the micro USB from my Amazon echo and it worked.