Servers by jDrones

Params check please


(Chris Olson) #38

I looked that ESC up and it says it has an optional programming card for it. But it does have a governor and it can be programmed with the transmitter sticks too. So there is a way to adjust the speed on it if you’re using the governor feature. It might be a “simple governor” like Align ESC’s too, and you could try increasing the throttle setting to see if it runs faster.

I’ve used that app on my phone before and it worked pretty good. It works on sound and it may have been picking up something else when you got your 3155 rpm reading - there is no way it is running that fast. When I used it I tied the heli down and put some pitch in the blades so it was creating lift and it seemed to be pretty accurate. You may have entered the wrong number of blades, or put in the wrong estimate of what you think the speed is. The app relies on that to discard other noises outside that range. I think you are running around 1,700-1,800 rpm judging by sound in your video. I would put the estimate at 2,000 as that only has to be +/-500 of actual, and see what it says.

it works best to lay your phone on the ground near the front of the heli so it doesn’t pick up the sound of the tail rotor quite so easy.


(FRED GOEDDERT) #39

Chris,
I have 2 YEP ESC and the programming card.
In this link on Youtube https://www.youtube.com/watch?v=7e-HL5k8ojI the person is trying the Governor store with that ESC and the card for his SAB Goblin. It is by far not that easy and good as the Castle Heli ESC,s. But you can get it to work with a lot of trying.
I will use from now on the Mode 3 in ArduPilot FW for Heli only. It is very nice!


(Chris Olson) #40

If your governor is disabled, I would highly recommend the Mode 3 throttle. It is one of the best new features for heli to come along in quite awhile. With the throttle curve properly tuned, it is perfect for scale models, either turbine or electric.


(OAPpilot) #41

Would Mode 3 be a better way for me to setup? I checked the Revs with my phone and I got 2160RPM with it just lifting off the ground. I looked at the video’s Fred said, I still can’t see how i can vary the Revs, even with the card.


(Jakob Schmidt) #42

I’m running a YEP esc on my protos 500 and can confirm that it has a governor.
You calibrate the governor first (I can’t remember the exact sequence) and then you modify the ch8 output in mode1 to set the desired head speed.
I have a 3-way switch set up on my Taranis to modify the ch8 output, so that I get 2150, 2300 and 2600rpm.

EDIT: YGE is the same as YEP, so follow this for setting up the governor:


(Chris Olson) #43

Well, it might be immaterial. If you’re at 2,160 you’re right in the ballpark. But what is your collective pitch range? Why is it taking so much collective to hover it? That doesn’t seem right. I noticed from your log that you have your IM_STAB_COL’s set to about 80% collective for Stabilize hover too.

IM_STAB_COL_1 330
IM_STAB_COL_2 750
IM_STAB_COL_3 850

You are using Mode 1 (RC passthru) throttle. So how do you have this set up? From your log it looks like you are either turning it up with a knob, or using some sort of transmitter mix to increase throttle

In your flight video I thought I heard the RPM drop part way thru the flight, and the log shows the same thing - your throttle signal dropped from 1570 pwm (slightly over 1/2 throttle) to 1510 pwm (about dead on 1/2 throttle). I don’t know if you are using the governor or not in your ESC, but obviously it is responding to throttle.

How much negative pitch do you have set up? I see you are using IM_STAB_COL_1 set to 330, which is 33% of your collective pitch. For a scale model I would NOT use that much negative pitch in your setup. Set the H_COL_MIN to no less than -2.5 degrees so you can autorotate the model if you need to. And set that IM_STAB_COL_1 to 0.

I suspect you have a lot of negative pitch set up, and are using the high IM_STAB_COL_1 setting to get maybe zero pitch in Stabilize? This is ok if you are an aerobatic pilot. But helicopters do not require that much negative pitch otherwise. It is just going to make the heli very jumpy on the collective if you switch to any mode other than Stabilize.

As long as it appears to respond to throttle, you could change to RSC_MODE 3. And there is five throttle curve settings.
H_RSC_THRCRV_0
H_RSC_THRCRV_25
H_RSC_THRCRV_50
H_RSC_THRCRV_75
H_RSC_THRCRV_100

Based on what I see in your log I would set these to:

  • this is your ground idle, rotors turning with collective all the way down after you throw the throttle switch
    H_RSC_THRCRV_0, 250

  • This one will control how fast she ramps up as you increase collective pitch. Here we’re going to ramp up the throttle from ground idle to 50% power by the time the stick is at 25% of the way up.
    H_RSC_THRCRV_25, 500

  • This one should be light on the skids about ready to fly - we’re at 60% throttle here and the stick is half way up.
    H_RSC_THRCRV_50, 600

  • You should be in flight by now - this is 75% of the collective pitch and we are now running 70% throttle
    H_RSC_THRCRV_75, 700

  • This is your max power setting for when you heavily load the collective. It will prevent rpm loss if it is set correctly.
    H_RSC_THRCRV_100, 850

The above throttle curve settings are just a guess. And assuming you are not using the governor in your ESC. If you are using the governor, the throttle curve might make it increase speed in steps. I don’t know how the governor works in those ESC’s.

If you try this, I would suggest setting your IM_STAB_COL’s 2 & 3 back to 400 and 600, and IM_STAB_COL_4 to 1000, so the collective is linear. Then spool up and lift off in Stabilize. See if it acts, looks and sounds like you want. When it lifts off glance down at the collective lever and see where it is on the quadrant. If it’s at half-stick you are at the 50 point on the throttle curve. If it’s slightly above 1/2 you are between the 50 and 75 points on the throttle curve (which is where you should be).

You can use this to tune your throttle curve points to get the rpm you like, get it to ramp the way you want, etc… Once you have it to your liking, then reset the IM_STAB_COL’s 2 & 3 back to where it hovers at half-stick in Stabilize flight mode. And you should be able to leave IM_STAB_COL_1 set to 0, and IM_STAB_COL_4 set to 1000.

Those IM_STAB_COL settings are great for sport pilots that like to set up a lot of negative pitch. But for the rest of us, you really only need to adjust IM_STAB_COL’s 2 & 3 for stick position in Stabilize hover, if you set your pitch range from -2.5 to +10


(OAPpilot) #44

Chris, My Taranis has no added input to the setup, switches or curves.The weather look grim for the next few days, So I think I will remove the body to get at the ESC, and check how it is setup. I will turn off the governor, if it switched on. and then try the mode 3 route. I will then work through the setup you offer. I will back up.the Param’s file before I do.
I will also do a check on the collected pitch range, and post that before I remove the body.

Geoff


(Chris Olson) #45

Sounds good Geoff. If we go to the throttle curve then we have a very easy way to adjust headspeed to whatever we want, and properly tuned it matches a governor for holding headspeed, no problem. With the added advantage of having a ground idle when you drop pitch, so when you land you can idle it down right away before killing the motor.

I’m pretty sure you’re running a lot of negative collective pitch, just judging by your H_COL settings and the IM_STAB_COL. I think you’ll like flying the helicopter a lot better once you get rid of that, as your collective movement has smoother and more gradual control when switching flight modes. And it’s not near so touchy in flight for the autopilot.

The original recommendation used to be to set -8 to +10. We’ve since revised that rec to run -2.5 to +10 or +11 unless you are flying sport where you actually need the negative pitch. -2.5 is safe for symmetric airfoils as they stop flying at zero pitch no matter what. -2.5 allows you to increase headspeed in autorotation if you get an accidental blade stall. For asymmetric airfoils you’d probably want to check your airfoil type to see what negative AoA it stalls at. Hopefully the manufacturer would have some specs on that - and set the neg pitch accordingly. Some lift-type airfoils can still fly (create lift) at -2.5.


(OAPpilot) #46

Chris, I checked my Pitch settings .On the first settings I have, H-Col_Min -9.6deg, Mid 0.0deg, Max 12.2deg. Then the stick settings are Zero. -2.3deg, Mid stick. 7.6deg, Full. 11.0 deg. My blades and the standard Trex 550 Carbon Fibre ones.


(Chris Olson) #47

Geoff. No wonder it hovers at 80%, and is what I suspected. I would suggest a more scale setup with -2.5 to +11, mid at zero. Set the IM_STAB_COL’s to 0, 400, 600, 1000 to start with. Set the H_CYC_MAX so you get 8 degrees of cyclic pitch, and use the Mode 3 throttle curve.

This is going to make a big difference in fly-ability of your scale heli.


(OAPpilot) #48

Hi Chris
I’ve attached the new Param’s file, after checking the ESC governor, is switched off. I’ve reset all the blade pitch settings to +10, 0.0, -2.5. Could you please check if there is anything else that I need to change. If all OK I will put it back into Bell 222 body. then wait for a good day for testing the new 5 point curve.

Just after Mode 3 setup.param (13.7 KB)


(Chris Olson) #49

Geoff, it looks good here. Just want to verify that this setting is giving you 8 degrees of cyclic pitch
H_CYC_MAX,1800

With the heli level, set H_SV_MAN to passthru, carefully move your collective to get zero pitch. Then move the cyclic full deflection in a circular motion to see what your maximum cyclic pitch is. This is probably the way you set it, just wanted to verify that.


(OAPpilot) #50

Chris, I’ve reset to these numbers, setting H-Col-Max to 11degs, H-CYC-MAX to 8degs.

new%20settings


(OAPpilot) #51

Just done my first test flight with Mode3. Again limited for flying space (Garden). It seems to be behaving OK. Looking at the log the vibrations appear to have increased. I will have a look, and try to find the cause.
It is hovering at about 68% stick, which you said to expect.

Geoff


(Chris Olson) #52

Yes, Geoff. It’s looks pretty good, still a little unstable in the pitch axis and looks like tail bounce and the autopilot is doing a lot of correction for it. But you can now play with the headspeed by adjusting the five throttle points to get the throttle advance you like for spoolup. As well as adjusting the 50, 75 and 100 points for how much power or headspeed you want in flight.

The vibration may be due to running a different headspeed than you had before and it may not be in the “sweet spot” for your drivetrain and blades for least vibration. When you get in a wider open area I’d play with those throttle settings a bit and see if you can find a speed it really likes and seems more stable. Typically, higher speeds are going to better than lower for vibration (less vibration).

This is one of the nice things about that new throttle curve. Most governors require a programming card/box - the throttle curve works just as good and much easier to tweak the rpm you want by making some settings in your ground station on-the-fly. If you do it while hovering in Loiter though, be very careful about entering the right number in flight. If, for instance, you want to change the 75 point from 700 to 750 while it’s hovering to see the difference, do not accidentally enter 75 and click “write” to the FC. It will cut the throttle right back and she’ll come down.


(OAPpilot) #53

Not been able to get to the field (to windy) until today. It was still a bit windy, 13mph. The heli took off nicely, then took it up to about 6metres high. put it into PosHold. It moved about a bit. Was this caused by the wind, the Bell222 body,or in the setup? Decided not to do the auto flight, until I was sure all was OK.

Bin file attached


(Chris Olson) #54

Geoff, the position controller messages indicate the wind was pushing it around a bit. The attitude controller looks fine. However, I noticed when looking at your log that your output from the RC radio on channel 1 and channel 2 is not steady. It is varying all the time by about 1 pwm. Dirty pots on the right stick control?

The left stick looks fine.


(OAPpilot) #55

Hi Chris, I changed both off the Gimbals on my Taranis to HALL EFFECT ones. They feel nice. To-day we had a nearly windless day, so I got a Auto flight in. It was a good flight, but I appear to be getting a bit pitch wabble still. Is this the best I will get with this Bell222 body?. I didn’t get any video. I’ve attach the bin file


(Bill Geyer) #56

Geoff,
I’ve been investigating the flying characteristics of different rotor heads. From what I’ve seen to date which is based on two to three different rotor head, is that the stiffness of the rotorhead plays an important part in the flight characteristics and the tuning. How stiff are the dampeners in your rotor head? If you can get stiffer dampeners, it is possible that you can push the natural frequency of the pitch motion higher which could help to get rid of the pitch bounce through tuning. Again this is just my theory based on what I’ve been doing with rotor head characterization. Ultimately from what I’ve learned in the research is that RC helicopter’s rigid body modes of motion are much more lightly damped which limits the use of P or D gain in tuning the aircraft and results in undesirable characteristics like the pitch bounce. The best option is to use something that introduces mechanical damping like a stablizer bar or flybar or heavier (i.e. higher inertia) blades. I believe that we will have to design special control laws for heli’s that will help improve tuning and resulting flight characteristics. FBL designers must have cracked the code on this which allows them to better tune helis.


(Chris Olson) #57

I agree this one is likely a mechanical issue that we can’t currently fix in software. Trying either stiffer or softer dampers would be worth a try. The articulation of the head in RC heli’s does not have the engineering that full size has where we have lead/lag dampers, etc… RC heads are kinda crude in comparison. Even the amount of torque you have on the blade grip bolts can affect this if one blade lags more the other. On all of my Trex models I’ve always ended up carefully balancing the head and locking the blades down tight to get rid of the inherent “pitch bob” problem they seem to have running less than 3D headspeed. On one of them - my 600 flybar that was prone to this - I replaced the Align blades with Rail 606’s and the simple thing of replacing the blades with different airfoil removed the pitch bob tendency and it never happened again. It actually flies better with the grip bolts more loose so the lead/lag hinges can work with the Rail Blades. With the Aligns I had to have it locked down tight like a rigid head.