Parameters to avoid stalling

Morning all

We are flying a fixed wing aircraft using the latest version of mission planner, along with Ardupilot Mega. APM 2.6, and have attached an air speed indicator. After a number of suspected stalls, under autopilot, I would be very grateful if someone could confirm I have made the correct settings within the parameter list, to ensure that the autopilot knows and will react when the airspeed falls to a critical point.

The airspeed indicator is certainly working, it fluctuates between the normal 1-3 values when on the ground at rest and increases dramatically when blown into. For the Parameter list I understand the following two need to be set to 1, in order for the speed indicator to be enabled and used by the autopilot.


From I have calculated that for an aircraft weighing 109.3492 ounces and with a wing area of 876.370 in.², the stall speed will be 21mph or 9.4m/s. From reading up I guess I therefore need to set the following parameter;


So assuming I am on the right track, the big questions for me is, if I make these changes, write them to the plane and set it off to follow a way marked mission under full autopilot command, will it automatically maintain an airspeed of 9.4m/s or more ?

Follow up, if the answer to the previous question is yes, then if I put the plane into stabalize mode, will the autopilot still make use of the minimum airspeed parameter and attempt to increase airspeed if it gets too low?

Am new to this so there may be something basic I need to check first to get the desired behaviour, if so please say.

Thank you

[mf]GCS/Mission Planner[/mf]

It should but we have found this to not always be the case, even with a Pixhawk with EKF enabled. We too have had a number of stalls in Auto mode with the airspeed dropping from the normal 12 to 8 or 7m/s despite the ARSPD_FBW_MIN set to 9.

The plane in my mind, should NEVER go below ARSPD_FBW_MIN, ever! If it does it should throttle up and/or nose down. There is however something in the software that should do that exactly: the TECS system which controls energy, so if the plane is close to a stall it’s supposed to catch it but it doesn’t seem to work everytime. I don’t understand it but hopefully Paul Riseborough the designer will chime in here.

There is the tuning guide which I’ve tried to follow but its not simple: … ing-guide/
and I’ve also started adjusting TECS_CLMB_MAX ( … S_CLMB_MAX)

Unfortunately, you are correct. Arduplane does not always observe a minimum airspeed. It appears to be a bug and I have posted to that effect before (yes, complete with logs) and nothing has been done about it. As far as I’m concerned, I just treat it as a known bug…

Setting ARSPD_FBW_MIN about 3 M/S higher than stall speed has worked well for me.

Was wondering about that, to even set the ARSPD_FBW_MIN to the same as or close to the cruise speed?