Overpitch and roll in gps modes

i have been using apm 3.1.1in stabilize , loiter and RTL quite successfully fantastic!!
so i attempted a simple auto mission . which failed (crashed) with pitch/roll greater than 45 degs from the logs
and 100% throttle rapidly losing altitude and high horizontal speed.
i have since moved the gps to a higher location but before i re test i am wondering about the excess pitch /roll condition.
I presume pitch roll is limited in stabilize mode?
then navigation is a second layer on top of stabilize ?
are there any pitch roll limits in the parameters list?
is it possible that 100% throttle means no headroom for stabilizing?

no idea if this is something related, maybe:

i had also strange twitches on the motor outputs in auto missions.

I have found several other problems
twitching in stabilize,
compass on 360 turn reads north, east, back to north ,west ,then back to north??
(works fine on ardu plane??)
earlier i had some osd incorrectly connected problems. i think the multiplexer is blown
but other wise it seemed to perform ok,
i now have a replacement board and all is now performing great!
I will investigate “faulty board” and post a conclusion later

update on faulty board?
i have erased eprom from terminal ,loaded plane (compass works ok) then loaded quadx 2.9.1
and compass works ok
however then upgrading to 3.1.2 i have erratic compass readings on planer
the twitching in stabilize has stopped
this may have been a one time radio issue?
so i will continue to use 2.9.1 for now and see how it goes

Tim Painter

Hi all
seems to me that my board was damaged in several ways when i incorrectly connected my minim osd
(grounds were separated not recommended)
plugging in an external compass and cutting the link has solved the strange readings from internal compass using v 3.1.2
I now have a replacement board and all seems well
I think I will call this one solved thanks all
Tim Painter