OSD will not display flight mode

Just upgraded from an APM to Pixhawk and my flight mode will not show on the screen. It says MOD on the screen but nothing shows up next to it. Updated the firmware ( 2.1.2 I think ) and updated the Char Set and had no results. I am using a PPM encoder with a Specktrum AR8000 receiver just like before. Mission Planner on my laptop recognizes when I change modes but just blank next to the word MOD on my video screen. Any Ideas??? I am running 3.1.5 Traditional Heli.
David R. Boulanger

Please have a look at viewtopic.php?f=72&t=6402&start=10#p21422, maybe it’s the same issue. It showed the flight mode before changing to Pixhawk?

Best Regards,

Everything worked fine with 3.01 and my Apm 2.5. I tried loading 2.2 extra on the OSD and it solved the flight mode problem but the I lost other stuff. Ground speed, Alt, Gps and others all just read 0. I can live for now with not having the flight mode because I always have my GCS running when I fly . Its set up to speak to me when I change flight modes. When I have a chance I may load 2.2 ( not extra ) and see if that helps.
May not do that until 3.2 is released for Traditional Helicopters. Thanks for your input.
David R. Boulanger