Oscillation in Loiter following tuning of x8

After recently tuning the copter using autotune I am happing with how the copter is flying though when switching to loiter it begins to oscillate, the longer I let it in loiter the worse the oscillation becomes… I was hoping someone could look at the log and give suggestions - I recently made physical changes to the copter to get rid of clipping on 3rd accelerometer, clipping is no longer an issue. I saw some other posts with loiter oscillation issue but those logs are removed, so hoping someone could have a look and give me some direction… log link below - note I have slightly modified the notch filter after this flight

I would update to latest Stable firmware 1st.

There is a lot of noise in the Rate output. You want these in the ~0.1 peak range:

The result is pitch, roll and motor output oscillation which you can easily see by graphing those parameters. The PID values look high for both pitch and roll. Did Auto Tune do that? If so you may want to start back at default, set aggression back to default (0.1) and try again. It wouldn’t hurt to set INS_ACCEL_FILTER to 10Hz.

Thanks Dave, it was autotune… the first try used .1 and the PID seemed high, next time i tuned using .08 and they got higher… changed PIDs back will autotune tomorrow, weather permitting

How does it fly on Default PID’s?

It flies soft but had little vibe I used it for over 2 years like this but I knew it was not as good as it could be …xfacta had helped me set up the notch filter. another friend helped with some new PIDs prior to running autotune and was gonna do the tuning but I decided to try to autotune myself as I have 2 other quads same size that really run nice thanks to autotune… But the X8 is trickier…could be the kde 3510-475 with 12.5" props (which should be ok) maybe the motors want bigger props?- but I think I can get it tuned. Everyone has been very helpful on the community

I tried autotune today after restoring my old lower values and updating the firmware to current release… Again the PIDs return similar to the current results…

I do have a question, why does autotune set P and I to same value?
A friend who initially set the parameters to get me started used a higher P rate than I rate. I believe he purposely left the values low so it would be easier for me to fly,

Almost always this will work the best. There is no explanation why here but its the recommended procedure:
Manual Tuning

I think you will have to manual tune. I think Auto Tune is setting those PID’s too high. I would usually use Live tuning.

@dkemxr what did you toggle in the bin log to show the rate output?


Rate>Rout and Pout

Thanks Dave, …
last question (I hope)

I started to set initial parameters for manual tune. wanted to set Rate/Roll Pitch from the channel6 menu and it is no longer there (see attached image). Can you point me to how this is done now? Thanks

Wrong place to look. It’s the Tune pull-down Rate Roll/Pitch kP

Thanks Dave
is there an expected rule of thumb as to approximate rate value for the Rate Roll/Pitch kP? per the copter size cell count motors/ props ect… as autotune set these to 14 and 17 and causes severe oscillation. yet when I manually fly it appears a range of 5-6 works to remove oscillation and looks close to the .1 peak for rate out you suggest.
Or are there other things that I need to look for to cause oscillation?


This will adjust the ATC_RAT_PIT/RLL_P value. Values in the 14-17 range would be the ATC_ANG values. The Tube parameter for that is STAB Roll/Pitch kP. And no rule of thumb really.