Only Top Motors Arm - Ocoto X8 Config

I have a custom build with PixHawk 2.1 Cube on an X8 Octo Quad. All motors pass phase 1 arming (chirp and twitch) when flight batteries are connected. Phase 2 arming passes (Flight Controller fires up, I get GPS signal and Transmitter (X9D) connects. On Phase 3 arming (long tone, spin up motors), only the top motors spin. The bottom motors stay in beep/twitch.

Troubleshooting steps taken:

  • Verified batteries charged
  • Verified physical connections are good
  • Verified full power and voltage are getting to ESCs and motors
  • Verified no changes have been made to FC parameters
  • Moved bird on 3d axis, top motors respond to try to stabilize, bottom motors do nothing as they have not armed.
  • Calibrated ESCs

Any recommendations for what to try next?

Make sure your ESCs are connected to the appropriate Main pins on the pixhawk as seen below.

Also make sure Frame_class is set to 4. This doesn’t auto set when firmware is loaded onto the board so if it is at default that would make sense as to why only the top motors spin.

1 Like

Thanks. These settings are all correct. We did some additional troubleshooting which is leading us toward changed configuration in Mission Planner that was ultimately loaded to controller.

Is it possible the params file created on an older version of Mission Planner would become corrupted and cause symptoms like this if it were manipulated (downloaded and uploaded) using newest version of Mission Planner?

Backstory: Bird was designed and built - fully operational. Then shipped. Upon receipt, first thing we did was connect to Mission Planner and download the params file so we had a backup. When built, designer was not using the most recent version of Mission Planner but we are.

We know ESCs and motors are working. I can get them all to spin by connecting ESC controller lead directly to the X8R Receiver throttle (pin 3). The bottom motors are just not getting signal to start spinning from flight controller.

Provide the param file and people can check it.

Full Param List 20191123.param (14.4 KB)

Update: Appears to be Pixhawk programming related but I’m at a loss because everything looked ok to me. Everything functions normally EXCEPT Pixhawk is not communicating with bottom ESCs (motors 5-8).

I have directly connected every ESC signal cable into RC3 on X8R receiver. I can arm and control every ESC and motor from transmitter so they all appear to be working ok.

When I plug ESC signal cables for TOP motors (1-4) into any Pixhawk main out 1-8 and arm, those motors will start and I can control throttle from transmitter. When I plug BOTTOM motors into any Pixhawk main out 1-8 and arm, nothing happens.

I just tried transmitter calibration followed by ESC calibration. On ESC calibrate, only top motors spun. Then tried motor test. Only A, C, E, G spun and pass. B, D, F, H did nothing.

Everything worked and it flew. We packed and shipped drone. Upon receipt and reassembly, bottom motors would not arm and also found red power lead for a bottom ESC had a broken solder joint on PDB. Solder joint was fixed.

The only other things that’s come up is a difference between Mission Planner versions used. Could this have anything to do with it?

Version used to initially program Pixhawk prior to shipment:
Mission Planner Version
Mission Planner Build 1.3.7222.33384
ArduCopter 3.6.2 (25f72536)

Version currently using to troubleshoot and reload saved params:
Mission Planner Version 1.3.68
Mission Planner Build 1.3.7105.26478
ArduCopter 3.6.11 (f0d59294)

Thank you in advance for timely responses and recommendations.

These look correct:

SERVO_x settings look OK, assuming all your MIN and MAX values are OK at 1000 and 2000 and match your ESC calibration.

These arent good and might be affecting things, maybe even part of the problem:

Also best to set these probably like this:
BATT_FS_CRT_ACT,1 (land)

While you’re at it, try setting this to the maximum amps your power system can supply. For example if your power distribution board, current sensor, batteries or connectors can only safely handle 60amps. Set according to the most fragile component in the chain.

This just occurred to me:
Are the ESCs all the same? Top and bottom ESCs the same?
Are the ESCs true opto-isolated and actually need a 5v supply for the PWM input to work?

Thank you very much for taking the time to look things over and the quick reply.

Flight batteries are two 6s in series: 30,000mAh each
PDB is APD PDB500 12S 52V 500A made by APD in Australia
ESCs are T-Motor Flame 80 (80A continuous and 120A max)
Motors are T-Motor U11 KV120

So MOT_BAT_CURR_MAX would be 80?

Looking at SERVO_x MIN and MAX vs. ESC Cals.

Thank you again.


WAIT - realisation number 2 !
You had parameters set as if using 3 cell, then you say you’ve got 2 6 cell batteries in series, which makes 12 cell . All those previous settings will need changing.
Please confirm if the batteries are supplying 21 volts or 43 volts.

If the batteries are 30000mah 25C then that’s 750amps
8x80A for the ESCs = 640amps
PDB = 500amps
8x60A for motors = 480amps

I’d probably set MOT_BAT_CURR_MAX 400 and do some tests flights.

These will need to be changed again.

Supplying 43 volts at 12s.

OK, try these:

Make sure your current and voltage sensor are reading accurately. I think that one you have comes with values to plug in.

And run the ESC calibration again

No change in behavior.

I’m working to wipe the Pixhawk completely and start over which has created separate and presumably unrelated obstacles. First, did the wizard get removed in 1.3.67 and 1.3.68? Per recommendations in other discussions, I wanted to load plane or rover and then reload copter. But I was using 1.3.68 and wizard was not on the left side menu.

I moved to another computer and found the wizard using 1.3.66. Things were looking promising all the way to step 16 and then the program hung. From that point forward, the wizard started failing on the battery capacity screen because somewhere in the firmware update process, 15 parameters were deleted. BAT_CAPACITY is the critical one at this point. Because I don’t have that parameter in my tree, I can’t proceed. I’m not sure procedures to add those parameters. Combing through community posts and documentation now.

Don’t bother with the Wizard. Just manually step thru the Mandatory Hardware and whatever Optional Hardware you have (battery monitor, etc). 1st thing I do after flashing to default or a new installation is to set the Frame Class and and Type in the Full Parameter list, reboot the board and then run thru the Mandatory Hardware.

Anytime you encounter messages as you have noted or greyed out functions in Mission Planner skip right to the Full Parameter List and configure there.

Closing out this item as resolved. Recapping:

Post-shipment, Octo-quad X air-frame was failing phase 3 arming (top motors would spin; 2/4 bottom motors would stay in phase 1 arming (beep/twitch) and the other 2/4 appeared to have no power).

Systematic troubleshooting revealed a few issues occurring in parallel. Distilling down to the main issues:

  1. An XT-90 connector (PDB to ESC) had come undone.
  2. A broken solder connection was found on PDB (a separate XT-90 connector end).
  3. Disconnected signal lead for standalone BEC.

After #1 and #2 were repaired, all motors passed phase 1 arming but only top motors passed phase 3 arming.

#3 was resolved when we confirmed that bottom ESCs were OPTO ESCs and that the standalone BEC lead was not connected to Pixhawk. After the lead was connected to Aux1 on Pixhawk, all motors passed all arming checks and full flight capability was restored.

Thank you everyone who helped with recommendations for investigation and troubleshooting.