One of the quad copter's motors stops spinning


When I run the drone’s motors with a radio controller, only the second motor (lower left) spins weakly. When I turn it down, it stops at the very beginning while the other motors are still spinning. I would like to know why this problem occurs and how to solve it.
By the way, when I replaced the pin of the motor, the motor worked fine, so I don’t think there is a problem with the motor itself.

ArduCopter V4.0.7
Frame: QUAD
Raspberry Pi 4B
Controller: navio2

Perform radio calibration.
Perform ESC range calibration.
And use the motor test feature of mission planner.

Thanks for the reply.
I have already done the radio calibration and ESC calibration. Also, in the motor test, all motors are spinning fine.

Is the copter tied down? If it is the results of the test of second motor are invalid. ignore it.

I’m sorry. What do you mean by “copter tied down”?
Checking the rotation is done on the ground, without the propeller.

Motor order test is done on the ground with no propellers using the motor order test feature of mission planner.

Motor tests of ANY kind can NOT be done with no propellers using the RC radio. A closed loop system can not be tested in a open loop configuration. The results are invalid.

Could it not be just MOT_SPIN_ARM which is a bit too low and just on the edge of where the ESC operate?
Which ESC’s are you using?

I’m using the ARRIS 30A ESC for multicopters. The firmware is Simonk.

If you have an isolated FC you can do some basic testing without props on.

the motors will respond normally. it is also a good way to see if your arming on the bench as opposed to on the hot tarmak. I did a small video on the subject. non isolated FC will give you vibration issues and is not recommended. I do the basic arm, ramp up and wiggle the sticks right and left and let the craft disarm as one of the last setups until i get in the air however i would not just let the motor spin for a long time or at full. Little peace of mind before the real flight.