OmniBus F4 v6.1 + ArduCopter 4.1 EKF2 is not enabled

I need exactly EKF2. I am currently using EKF3. I am trying to switch (AHRS_ELF_TYPE = 2) to EKF2. Then I send the parameters to the Mission Planner and reboot the flight controller. But after rebooting, it’s still AHRS_EKF_TYPE = 3. I also tried to set EKF3_ENABLE = 0 first, but the same thing. In addition, there are no parameters in the Parameter List that relate to EKF 2. What am I doing wrong? Maybe there is still some setting?

If your board does not have enough memory then EKF2 will not be compiled in. You will not be able to select it then. Does your board have 1MB or 2MB?

Hmmm…if you mean flash MCU, then no more than 1MB. Or you mean SPI Flash?