Odd ROI behavior after Follow-Me

I observed something weird this evening. I tested Follow-Me mode several times, which worked great. I had the copter follow me to where I launch from, put it in Loiter, and landed it with the TX.

Next, I set several waypoints on the map. Nothing fancy, no splines, and (importantly) no ROI. I launched and switched to Auto. As soon as I switched to Auto, it turned to face the last point it was looking at in Follow-Me mode, and sped off on the mission. It’s almost like the last followed point gets left in place and is used as the ROI. Is that possible?

Also, while I was playing with Follow-Me, I tried to use Guided mode to send the copter far away so I could switch back to Follow and have it come across a field toward me, but it didn’t actually go where I told it to. Same issue?

How about providing tlogs and/or data flash logs to help troubleshoot your issue.

Sorry about that, I noticed the log extraction in APM planner isn’t working terribly well (I wrote it, it’s my fault, will fix). Here’s the log.