OctaPlane PWM and Motor mapping issues

I have been working on a quadplane project for the past few months with mixed results. This airframe is a 3 meter wing span custom design flying wing weighing between 12-15kg. I started off with a quad setup for the VTOL capabilities. I had some very unfortunate problems with the quad motors and ESCs though which led me to the decision of an X8 configuration. I loaded the latest Copter X8 firmware and started testing without the wings attached… all was well and I was able to tune the setup well and had good results. I then loaded the latest Plane firmware, leaving Q_Enable at 0 I bench tested the plane equipment and all seemed well. Then, I set Q_Enable to 1 and copied over the Copter X8 PID settings. Once changing the Frame configuration to Octaquad (3) all kinds of things were screwed up… The plane motor esc was no longer receiving a PWM signal and the control surface servos were acting very strange, humming and moving on their own regardless of flight mode. The octa motors did however work normally. I tried plane firmware from 3.5 all the way to the latest 3.7 with the same results. I just loaded the beta 3.8 and this problem went away. All systems work properly. However, the motor mapping on the octaquad configuration is not right.
I setup with octaquad motors as suggested in the wiki:

Ch5 = motor 1
Ch6 = motor 2
Ch7 = motor 3
Ch8 = motor 4
Ch9 = motor 5
Ch10 = motor 6
Ch11 = motor 7
Ch12 = motor 8

I have the ESC labeled by location, not # to make things easier.

Ch5 - motor 1 = Front Right Top
Ch6 - motor 2 = Front Left Top
Ch7 - motor 3 = Rear Left Top
Ch8 - motor 4 = Rear Right Top
Ch9 - motor 5 = Front Left Bottom
Ch10 - motor 6 = Front Right Bottom
Ch11 - motor 7 = Rear Right Bottom
Ch12 - motor 8 = Rear Left Bottom

When I use the motor test menu, these are my results:

A spins motor A
B spins motor E
C spins motor F
D spins motor C
E spins motor G
F spins motor B
G spins motor D
H spins motor H

I was able to switch inputs around until A=A, B=B and so on but the mapping is still messed up in the firmware. Control inputs don’t match motor outputs.
I checked the RC outputs to verify their channel mapping and they seem accurate:

Rc5 =33

I then returned everything to default and decided to try changing the servo/rc output functions to correct the mapping issues. After some creative motor mapping, I was able to have all channels working properly… or so I thought.
I bench tested and everything seemed fine but its hard to tell while the aircraft is secured down. I took it outside and attempted a hover in QStabilize. Throttle, roll and pitch seemed fine but Yaw was not. I added a touch of right rudder and the plane yawed to the left and tried to flip over the nose. Not sure what this means other than there must be a mapping/control output issue.

If anyone is curious or has some suggestions, please advise.

Here is my param file.
UAS003_OCTAPLANE_7_5_17.param (16.0 KB)

Here is the log file… https://drive.google.com/open?id=0B1xMs13CkzYPa3BwekRtLXBPTjg