Obstacle avoidence not working in Auto mode

Hai Friends,
I am using light ware sf40/c lidar for obstacle avoidance. in loiter mode, it works perfectly. but if I put it in auto mode I faced some unknown obstacles and it behaved very abnormally. Can anyone suggest proper OA parameters for auto mode?

Hello @Rameshprabha_Karikal

Be careful to choose properly the path planner algorithm used by FC in OA_TYPE parameter, and check the documentations if all the options are working with distance sensor.
Also, it is a key point to properly set the OA_DB_ parameters right, in order to set the obstacle database that is built with incoming data from your sensor. It dictates things like the obstacle maximum distance that will be inserted into database and the persistency of this data inside database.
It would be useful to post some logs in order to better evaluate what is really going wrong with your system.