Servers by jDrones

Not arm or disarm with transmitter

Hi everyone,
I can not ARM or DISARM the helicopter with my transmitter but I can ARM or DISARM it with MP from my laptor.
Attached log, thanks in advance.

https://drive.google.com/file/d/1z1zStHtGSCHjoZGKw_iIIPmvcGMEsAV-/view?usp=sharing

@Loren_DS can you provide a little more context? A log is wonderful but sometimes issues can be resolved quicker with some more information. So having a little more background on what has changed about your set up or when you first noticed this issue is very helpful. Plus it tells us what you have done to troubleshoot the issue.
Is this a new setup?
If not, did you recently change settings? If so, what settings?
Did you recently upgrade your firmware?

Hi @bnsgeyer ,
I have not changed any configuration or settings or firmware, since day one I cannot arm or disarm from the transmitter.
It is the first time that happens to me, I have other helicopters with the same version 4.0.1 and I have not had that problem.
I have not been able to solve the problem, from the first day I armed or disarmed it from MP.

Are using rudder to arm or a switch? Are you using the same transmitter with the same transmitter settings for this heli.

@Loren_DS

I am new with ardupilot too. But I think, maybe, your settings in the parameters could be the way to the solution of your problem. Therfore, I would post your parameter list too.

BR

Heri

Hi @bnsgeyer,
i use rudder to arm but not work, therefore I use MP.
I don´t understand this: Are you using the same transmitter with the same transmitter settings for this heli.

Hi @heri ,
How can I show all my parameters?

Do you use the same RC transmitter with the heli that has the problem that you use with your other heli’s that don’t have the problem. For example, I have one transmitter that I use with all of my heli’s. However, on that transmitter I have different setups defined for each heli. In my transmitter they are called models. So I switch to the synergy model in my transmitter when I fly my synergy helicopter and then switch it when I fly another one.
However if you use rudder arming then it may be a servo limit setting.

@Loren_DS

in the MP under the point “Config” you choose “full parameter list”. Here you can store the parameters in a file named “*.param” (use the button on the right side of the screen) (You can name the file however you want, maybe "TREX600Version1.param).

Everybody with the MP-software can load these file and see your parameters.

BR

Heri

Calibrate your transmitter and see if that fixes the problem
https://ardupilot.org/copter/docs/common-radio-control-calibration.html

Also check that rudder_arming is enabled
https://ardupilot.org/copter/docs/parameters.html#arming-rudder-arming-with-rudder-enable-disable

Yes i use the same transmitter for all helicopters (Futaba 18SZ) but with a little different configuration.
ok change the servo limit on my TX and now work fine.
Many Thanks @bnsgeyer.

1 Like

Thanks @heri for your information.

It is hard to see from the recorded log the reason, as the recording started after Arming.
Do you have any telemetry or tried doing it while connected to the mission planner ?
the system should give you a reason for not arming.

Hi @ZvikaF,
the problem was that my transmitter has limited the ENDPOINT of RUDDER. I Removed limit and problem solved.
Thanks.

Thanks for the update :slight_smile:

Servers by jDrones