Servers by jDrones

Not able to download dataflash logs-Pikshawk


(Hima Bindu) #1

Hi All,

I am trying to download Pikshawk datalogs via mavlink, I am not able to and it says time out, Now I even tried to download Via the CLI terminal and even then I have a screen with matter which I don’t understand, what is the problem.


(Samuel Salomão) #2

Have you tried Mission Planner to download the logs?


(Hima Bindu) #3

Yes I have tried Via mission planner to download the logs, first I tried Via Flightdata-Dataflash logs it did not work, it say times out. Then I tried via the TERMINAL window and tried to connect the pikshawk Via COM4 but it says initially waiting to reboot and then a flow of non-understandable matter keeps on flowing and when I press some key like enter on my computer the mission planner stops to respond and closes.


(Samuel Salomão) #4

Hi,
In the Flight Data screen, make sure you are able to connect to your FC via USB first.
If you can connect and then load all parameters, then try following these instructions:
http://ardupilot.org/planner/docs/common-downloading-and-analyzing-data-logs-in-mission-planner.html?highlight=logs


(Hima Bindu) #5

Hi,

Iam able to connect to the flight controller and load all the parameters, and see the sensor data. but I have only problem in downloading the logs.


(Hima Bindu) #6

Hi,

May be my CLI is disabled, may be that is causing the problem, I will try and update here.


(Hima Bindu) #7

Hi,

I enabled the CLI, Now in the CLI I see my set of logs, as seen below.

,

but when I go to Logdownload the log dropdown box is empty as seen below, what is the problem.


(gmorph) #8

The CLI is dis-continued so its not the right way to do it moving forward.

I’m not sure what the issue is but its better if your connected over USB to download logs but best of all is to remove the SD card and transfer them that way. Your other option is APSync - there is doco on the website.

Thanks, Grant.


(Hima Bindu) #9

Hi Grant,

Thanks for the information.