No throttle response from Pixhawk based 2014 Hex y

So I got the ESC’s calibrated, but I get no throttle response when I arm the motors. I see the throttle moving when plugged in and armed, but I get NO response. All the ESC’s were tested and work. I saw the thread about THR_MAX being too low, but I can’t find the setting anywhere in the software. Reaaaaly want to fly this little guy and get it working for our Uni program.

THR_MAX is set properly. I have followed all the instructions to the T. Upon battery plug in all the motors make noise. The pixhawk is green lit. The only issue I see is the red light on the arming switch blinking 3x fast, which means system check. I can’t find any data in the logs that seems out of place. Could I have a bad power distro board or Pixhawk. It is outputting a PWM signal, but that signal does not seem to be making it to the motors.

Took my top plate off to inspect the innards and some of the servo cables from the ESC’s to the PDB had come a bit loose. Got them all attached and decided to try the all at one ESC Calibration. I am only getting motors 1 2 and 4, 3 5 and 6 have ZERO response. Any Ideas?


Got it solved out! Turns out I had somehow done a Standard Y kopter on the firmware, Not the coaxial. In addition the ESC control wires were pulling out a bit as I put the kopter back together causing two motors (always random) to not start. Hot glue solved this problem.