No Terrain data mode change to RTL

AC 4.3.1

TF02 pro configured for downward facing for terrain follow.
RNGFND_ MAX = 2500

I have created waypoint height as a terrain .all waypoint height set was 50m.

In auto mode after reached 20+ m height mission planner says “terrain data missing mode changed to RTL”

I suspect that after range finder data missing it changed to RTL…
Can’t it use SRTM data which provide by mission planner for terrain relay only on Rangefinder?

You are saying to ardupilot system that your rangefinder can only have reliable readings upon 25 meters and sending your drone to 50 meters of height, so in this case, when your drone reaches 25 meters, ardupilot will change to RTL responding to a terrain failsafe… so it is all expected behaviours.

I don’t know if it is possible to have a “hybrid” configuration like this, ie, reading rangefinder inputs upon some height and then transitioning to SRTM… @rmackay9 any thoughts about it?

I know that some paid GCSs has some Software processing on the terrain maps prior to send a mission to the drone, so it can calculate relative heights that compensate for accidented terrains… just an idea.

@BrunoBagarini, @kalai1219,

I’m afraid that AP does not have a hybrid method (aka terrain database + rangefinder) although it has been brought up before (see second item in this issue). It’s actually not that easy to mix them because they can quite easily be 20m apart because the terrain database doesn’t include trees or buildings while a rangefinder will see these.

1 Like

So if i want fly the drone over big mountain at an altitude of 400m AGL with terrain altitude method I shouldn’t use down facing lidar since any way it doesn’t meet that height requirements for terrain to be follow.
AP can’t use the hybrid terrain method then there is no use of down facing lidar.

thanks @rmackay9 for the clarification!

If I am not mistaken, when you use a downfacing rangefinder, it can be used to aid in the final portion of the Land, but I don’t know if this is that valuable for you… maybe just in the case you have to land in other place than home and there is a huge barometric discrepancy between home and actual land point.


Yes, that’s right. For missions using terrain altitudes, you can force them to use the terrain database (and not the rangefinder) by setting WPNAV_RFND_USE = 0. This could allow you to leave the rangefinder attached in case you wanted to use it for other things.

1 Like