No servo output anymore despite Mission Planner shows outputs

Hi all,

first of all, I have to mention that I am new to ArduCopter.
I have a Blade 450X which electronics I completely rebuilt with a Mini Pix (including power module, GPS, ultrasonic sensor and so on). I have EMAX ES08MD digital metal gear servos built in and a FrSky Taranis Q X7 as transmitter including telemetry (ESC and motor are stock). My ArduCopter FW version is 4.0.7
I have attached my params here: Blade450X_params_20210804.param (18.0 KB)
I used the setup videos from Chris Olson which worked fine (see here).

So, my problem is:

  • When the receiver is switched on and the Helicopter has power the servos are not responding (hardware safety switch unlocked) and aren’t doing anything. Mission Planner shows that the servos are driven when I move my sticks on the TX.
    When setting up the servos worked flawlessly while having an orange blinking status LED.

After correcting the issue (FS PWM was set too high) my LED is now blinking green (and blue with GPS fix) and I tried to start up the engine (without rotor blades) but it did not spin and since then the issue above is occurring. (now I am using an external servo as RSC substitute for safety reasons and the ESC is unplugged from the Mini Pix)
I tested all servos and they are working flawlessly, all other components too…

  • Is this a hardware problem? (may I have damaged something?)
  • Or is some software feature preventing the servos from being driven?

I would be glad for any help!

EDIT: I tried to set H_SV_MAN to 4 or 5 (min collective and test mode) but no servo is moving…
The voltage I am getting is 0.9V. Is the voltage only switched on when the servos are enabled or always on?

I am very sorry for everyone read this thread.
I was not thinking enough that when plugging off the ESC all servos have no voltage!
So replugging the ESC of the Brushless motor solved the problem! :man_facepalming:

1 Like