Hi Gang

I’m having the most odd problem. I’ve installed the latest firmware (MinimOSD Firmware v2.2 Beta). Everything appears to work fine except RSSI. I’ve done the following.

  1. I’ve configured APM as outline here. In my application analog 0.
  2. I’ve checked the RSSI voltage from the RCRX and it’s a stable 3.3V.
  3. I’ve checked the RSSI voltage after the low pass filter and it’s a stable 3.3V.
  4. I’ve checked Mission Planner > Flight Data > rxrssi and I get 100 when the RCTX is on and 0 when the RXTX is off.
  5. I’ve tried over half a dozen times updating the CharSet via ArduCAM OSD Config v2.1.2.

Any suggestions?


Jase :slight_smile:

Please try with the 2.0 version: … -firmware/

Hi RogelioN

Thanks for the reply. I tried your suggestion and can get RSSI to work in 2.0 but the flipside is I’m no longer able to toggle through pages which I can with 2.2. :frowning:

In my search for a solution I discovered arducam-osd and minimosd-extra. Am I correct in thinking that minimosd-extra builds on where arducam-osd left off? What are the pro and cons of using minimosd-extra?

Really appreciate your help.


Jase :slight_smile:

PS I’m using fixed wing.


I’m sorry I can’t help with the pros and cons of the miniOSD extra firmware but it seems to be someone found a solution using “Switching by a momentary switch” ( … ange-mode/) and this is the post: