Servers by jDrones

No RC input with Arducopter 4.0.3

I’m new to remote control gadgets (at a technical level anyway) so I’m likely making a mistake. Hopefully someone can point it out.

My problem is that I can’t get flight controllers to “see” remote control input. At this point I’ve replaced my flight controller, transmitter, and receiver.

Originally I started with
Flight controller: Pixhawk 2.4.8
Firmware: PX4
Receiver: Tactic TRX600 (very old 72mhz fm receiver) with generic PPM encoder
Transmitter: Tactic TTX400
Now I’m using:
Flight Controller: Holybro Durandal
Firmware: ArudCopter 4.0.3 (ChibiOS)
Receiver: Spektrum AR620
Transmitter: Spektrum Dx6e

However, after flashing that flight controller over to Arducopter 4.x I got no inputs from the PPM encoder. I posted separately about that and kind of decided maybe it was just too old to work.

I went to the local hobby shop and bought the best remote they had in stock, it was a Spektrum Dx6e which came with a Spektrum AR620 receiver. The receiver supports DSM2 and DSMX. 6 channels and it will do 11ms or 22ms. The transmitter only supports 22ms but still either DSM2 or DSMX.

According to the release notes, arducopter has supported dsmx 22ms since January so all should be well.

The transmitter and reciever are bound to each other. The indicator light and the data on transmitter’s display show that all is well.

I couldn’t get the Spektrum transmitter/receiver to work at all with the pixhawk flight controller running aruducopter. Neither via DSMx nor using the PPM encoder. When connected via DSM, QGroundControl shows there are no detected radio channels. When connected via PPM encoder, the channels show up but there is no response when I move any of the controls.

I was only connecting the DSM/data port (vcc, gnd, data pins) to the pixhawk so I thought maybe I needed to supply power to the battery connector on the receiver. Spektrum says it likes 3.5-9v so I went with 9v. That was a mistake as the battery port’s VCC is connected to the VCC wire on the DSM port… 9v fried a couple of the chips on my pixhawk.

So I bought a durandal flight controller from holybro. Loaded up Arducopter 4 on it, and… have the exact same problem!

At this point I’ve tried two different FC’s, two different receivers, and transmitters. I can make the hardware work with PX4 firmware but it just won’t work with Arducopter at all.

Here’s a photo of my wiring:

Any help would be greatly appreciated. Seems like I must be missing something simple. I’m assuming there’s someone in the world successfully using arducopter 4, so it must be something I’m doing wrong.

There is a known problem with this receiver and Copter 4.0.x (and in fact with some other Spektrum variants). I don’t have one to test with so debugging is a little tricky. That said, you should be connecting to RCIN on the opposite end of the Durandal for PPM, not DSM which is for satellites only.

Thanks, I wasn’t sure and had tried it both ways… have the receiver on RC in now… unfortunately same results.

I was kind of lead to believe spektrum was pretty much the gold standard for RC controllers. Obviously I read incorrectly. What controller and receiver will work with ArduCopter? Honestly I could not care less as I don’t ever intend to fly with the remote. I intend to run preprogrammed flights exclusively but the setup seems to require RC to be set-up. Can you recommend a brand (or specific product) that definitely works with ArduCopter? The cheaper the better.

I think most of the developers use FrSky

And a lot of others besides the Developers. A $20 Frsky Rx will work great.

*I sold my Spectrum stuff ~5yrs years ago. I wouldn’t use an RC system that didn’t support OpenTx.

1 Like

Well so I bought a Frisky X10 Express and a frisky ACCST G-Rx6. Yes I know the RX is intended for gliders, but there’s an option to disable the variometer and it was the only Frisky RX that was in stock at the time.

I couldn’t get arducopter to acknowledge the frisky rx/tx with the frisky firmware. I’ve now got the TX flashed over to OpenTX. Is there an “open” flash I need to apply to the RX in order to get it working with Arducopter?

Basically, I’m stuck at the same point I was with the other Tx/Rx combinations I’ve tried. That is, Arducopter (actually, QGroundControl) complains:

Just to recap. Where have you connected the RX and what have you configured to enable it?

Does the Rx bind? Rx Sbus out to Durandal RC IN?

Can we get a picture of how the RX is wired to your FC?

As suspected, I had the connection incorrect. There is an “S Port” and an “SBUS_OUT” on the reciever. I had been using the S port. Switched to the SBUS_OUT and now the FC recognizes that there is a receiver connected!

Transmitter is running OpenTX 2.37
Receiver is running ACCESS 1.1.0/1.1.3

I’m still struggling, I presume with TX setup.

QgroundControl only shows LS and RS activity on channels 5/6 respectively. None of the other channels show any movement. I think I’ve at least got a tx paired with an rx, and that rx appears to be talking to the fc.

Thanks for the help so far guys, I might not have looked at that connection again if you hadn’t prompted me to do it.

If you have any suggestions for channels 1-4 then please don’t be shy :).

I’m having some really bizarre results. Initially only channels 5,6,7,8 were working (that’s why I was getting the two side sliders - they were on 5, 6). I moved the sticks over to those channels and successfully calibrated. After rebooting, it changed! Now it’s channels 1-4 that are working and 5-16 are not working.

Luckily it’s all open source through and through. I’m going to hook the RX up to an arduino and see if the problem is in the RX or if it’s in the FC.

Also, since I’m not planning to actually use the controller I guess I could just move on. I figured since I spent like 500 bucks on a transmitter that I’d actually use it but I don’t really HAVE to. Seems like a playstation controller hooked to a computer running QGroundcontrol will work just fine as well now that the pre-requisites for radio have been satisfied.

How do you know what firmware is on the Rx?

Because I flashed it. I guess the RX firmware probably isn’t entirely open source but the ACCESS protocol is well documented and open enough that there is an Arduino API you can use to read it. That will be enough to tell me if the problem is on the RX side or the FC side.

Servers by jDrones