No GPS satellites are being detected

Hello.
I am using Pixhawk Cube (black), HERE GNSS GPS module.
and Mission Planner software. I have connected the GPS
module to GPS Port 2 on the Pixhawk. The module is not detecting
any GPS satellites in an open area. Any suggestions on how to fix this ?

Keep the antenna away from electromagnetic interference sources, like USB cables and power supplies.

It is kept away from such equipment

What GPS status is given in the HUD on Mission Planner. “No GPS” or “No Fix”? If it’s “No Fix” then the autopilot is seeing the GPS but it just can’t get a position. If it says “No GPS” then it could be a parameter or hardware issue.
Also make sure that you have set GPS_TYPE2 parameter to “Auto” and that the SERIAL4_PROTOCOL = 5 (Serial4 is the UART port used for GPS2).
Is there a reason why you are using GPS2 and not GPS1 port?

Thank you. Will try it. The GPS1 port has come out that is why I am using GPS2 port

Hello. I have connected the GPS module to GPS Port 1 on the pixhawk2. The module is not detecting any GPS satellites in an open area. and mission planner says no gps .Any suggestions on how to fix this ?

replace the cable, and if that does not work replace the gps receiver.

After connecting to Mission Planner is the GPS found in the messages screen?