No gas, not stabilizing

Is there a way to get this working? When using Betaflight or Inav on a copter it will stabilize at “free falling”. I you’re high up in the sky you can pull the throttle all way down to get the copter falling but stabilizing.
If you do the same with ArduCopter it will fall like a leaf without any control. Have I missed some settings or can’t this be changed?

Many thanks in advance

if you dont have gps at all try to change these values

  • Disable GPS in non-auto** modes - set AHRS_GPS_USE to 0
  • Disable GPS_FAILSAFE
  • Enable Battery_failsafe to LAND only or disable (not RTL) - set BATT_FS_LOW_ACT parameter from Copter-3.6 or higher (for Copter-3.5 and lower use the FS_BATT_ENABLE parameter)
  • Enable Throttle Failsafe to LAND only or disable (not RTL or continue) - set FS_THR_ENABLE = 0 or 3
  • Disable FENCE - set FENCE_ENABLE = 0


Arducopter does not have an “Airmode”. Arducopters main goal is not race or freestyle flying, but waypoint missions etc. So if you pull the throttle below a certain percentage (I do not know the exact threshold right now) all flight calculations stop and it is not advised to do this while up in the air. You could program an “Idle up” switch in your transmitter, so that even if you pull the throttle down, it will not go to zero. In fact many freestyle/race pilots did this with clean/beta/etc. flight, before “Airmode” was introduced. And your problem got nothing to do with GPS…

1 Like

you can achieve sort of a ‘Air Mode’ by enabling a motor interlock switch.

Set MOT_SPIN_ARM_ARM to a value that does stabilize the craft when the throttle is dropped. You may also have to bump MOT_SPIN_MIN. Personally I don’t like spinning props on arming but this would work.

Thanks a lot. I’ll try these settings.
My drone is “over powered” and it’s a lot of fun to fly.
3D-printed, cf tubes, race motors
Omnibus F4 FC
4x35A 4S Esc
<600gram and about 2 hp of motor power.

I don’t really race but free style is fun and we have a nice field with “permanent” gates.

Drone building is very funny and I will probably get a class of youngsters to teach coming spring.

ArduCopter has far more features than Inav and Betaflight so I would love to see my drone fly as well as it did with betaflight.

For absolute beginners it will be perfect to setup “fences” for our field so they cannot fly away.

Thanks a lot for all answers

1 Like

can you explain how to do this? love to have working airmode in Acro mode.

set one of your RCx_OPTION switches to motor interlock (32)

I guess I don’t understand how being able to start/stop the motors on a switch can emulate an air mode

Air mode means props spin the whole time, so if your not expecting it exciting things can happen, so this is only enabled if you have the ability to stop the motors with a switch. ‘Air mode’ and trying to disarm using the sticks would be bad.

Its more left over from helis really. No is not a fantastic way of enabling it by if you want ‘air mode’ that is the only way currently.

ive already disabled Arm/disarm with rudder and have my arm/disarm set up on an aux switch. are you saying that airmode is not actually enabled unless I am using motor interlock basically as a way to arm/disarm ?

Yes, you must use motor interlock. you can have arm disarm too or not. Once you have interlock you can rudder arm/disarm.

in the wiki, it states that airmode is not active if your using rudder to arm/disarm but if you disable the rudder arm/disarm that airmode is active. so is the wiki incorrect?

maybe you can test it for us and we can update the wiki if necessary

This works great!
Disable rudder arming.
Make sure to have set a decent MIN RPM
Select a 2 (or 3)-position switch on you transmitter and output to a free channel
Set the RC input channel to 41 (Arm/Disarm).


Now when you toggle the switch and the arming check is done the motors starts and the copter is stabilizing. At flight you may lower the throttle down and the copter will descend without free falling.

Disarming is much quicker! No delay as when disarming by the rudder stick