No dataflash logs to download


I know this is a common problem but I am unable to get the dataflash logs to record. Currently I am not flying but just testing the board trying to record data while it is connected to the GCS via USB. I’m running Mission Planner 1.3.62, ArduPlane V3.9.8, and using a Pixhawk 1 board.Telemetry logs are being recorded successfully. I have tried using a different SD card, reformatting the SD card, and setting the ARMING_CHECK parameter to 0 and arming the plane. I have tried downloading the logs through Mission Planner and just by plugging in the SD card to the computer. So far everything has still resulted in no logs being created. Any help is appreciated.

it‘d be less guessing for those who want to help if you‘d post your current parameters and check if the folder structure is written correctly when you insert a freshly formatted card into your pixhawk. on top of that, you could use the console prompts to check for sd related issues. it‘ll tell you if the whole initialization process fails (that would result in no folder structure written to your card), or if there‘s log write errors (empty folders, no logs).

cheers, basti.